View Issue Details

IDProjectCategoryView StatusLast Update
0018016MediaMonkey 5Syncpublic2021-06-25 22:23
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0018016: Device free space is reported incorrectly in some cases
DescriptionAs reported here: https://www.mediamonkey.com/forum/viewtopic.php?p=482780#p482780
and as I replicated with my of my USB flash drives the device free space is calculated incorrectly, see: https://www.dropbox.com/s/28k420js0rlxtz8/screenshot%202021-06-11%2015.59.39.png?dl=0

This seems to happen when there is already audio/video content on the device that is no longer on the sync-list
TagsNo tags attached.
Fixed in build2419

Relationships

related to 0017901 closedLudek Sync list configuration changes fail to save in some hierachies 

Activities

Ludek

2021-06-11 19:58

developer   ~0063901

Last edited: 2021-06-11 20:11

View 3 revisions

Moving to 5.0.1: In addition there is a regression in 5.0.1: Playlists nodes checked on sync-list are not counted (only if they have some children playlists) -- introduced while fixing 0017901.

Ludek

2021-06-11 20:11

developer   ~0063902

Fixed in 2416

peke

2021-06-14 23:19

developer   ~0063938

Last edited: 2021-06-14 23:21

View 2 revisions

Verified 2416

Free Space looks like it is calculated correctly now, but when there is large number of tracks/videos on drive (Testing on 500GB External USB HDD) Bar showing Audio/Video is lagging as Scan on connection takes too long)

Further investigation and new bug needs to be opened for tweaking.

Test note: After initial sync Delete MediaMonkey Folder from drive and profile so that MM needs to scan device fully again and recreate profile in order to trigger slow update of device stats line.

peke

2021-06-15 18:17

developer   ~0063948

Looks like we have small regression https://www.mediamonkey.com/forum/viewtopic.php?p=482947#p482947 I can't confirm as for me MM5 warns that there is no space on device.

Ludek

2021-06-16 14:09

developer   ~0063953

Last edited: 2021-06-16 14:11

View 2 revisions

Items 2,3,4 from the forum link are fixed in 2417

This item 1) is related to device detection that I cannot replicate and I am waiting for a log, to be entered as separate Mantis issue once we have the log.

peke

2021-06-17 20:51

developer   ~0063974

Verified 2-4 in 2417

Left resolved till New bug is created according to logs.

peke

2021-06-20 12:42

developer   ~0064019

Re verified 2418

no issues.

Ludek

2021-06-21 11:27

developer   ~0064036

1) was fixed as separate issue ( 0018038 )

So closing...

Ludek

2021-06-22 15:33

developer   ~0064047

Last edited: 2021-06-22 15:51

View 2 revisions

Re-opened: There is still a mismatch in the calculation when playlists are sharing tracks, details here: https://www.mediamonkey.com/forum/viewtopic.php?p=483221#p483221 (item 2)

Fixed in 5.0.1.2419

peke

2021-06-25 22:23

developer   ~0064074

Verified 2419

Good catch.