View Issue Details

IDProjectCategoryView StatusLast Update
0017973MediaMonkey 5Install/Configpublic2021-10-28 22:37
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017973: Multi-Value Separator setting allows entry of multiple characters
Description1) You can fill in multiple characters in the separator setting (Tools > Options > Fields). As only a single character is allowed the field itself should not be able to take additional characters.

2) Using the drop-down auto-complete it adds the selected value to the existing separator instead of replacing it.

3) An option to allow for a leading space would be a good addition. For example using ; a space in front isn't needed, but using | as separator it would look better as value1 | value2 instead of value1| value2. This could be a sub-option.
TagsNo tags attached.
Fixed in build2512

Relationships

related to 0017971 closedLudek Alternative multi-value characters show as ; after editing field 

Activities

michal

2021-07-09 17:29

developer   ~0064198

Last edited: 2021-07-09 17:30

View 2 revisions

2) fixed in build 2500, it was bug.

I am not sure about the rest, currently we support space(s) + character + space(s), the suggested solution would decrease variability. I think current solution is ok, only we could automatically adjust value after entering not supported combination (e.g. with two nonspace characters). Rusty, what do you think? I.e. after entering ' Xx ' value would be auto-adjusted to ' X ' etc., currently it is auto-adjusted later and not clearly visible to user.

michal

2021-07-09 17:33

developer   ~0064199

Or we can add 2 checkboxes for setting leading space and trailing space. But for me it is unnecessarily too many controls to one simple setting, which users use only rarely. I would leave it as it is.

rusty

2021-10-13 14:38

administrator   ~0065155

I'm not sure if any changes are needed, since:
1) The reason for allowing > 1 character is to configure how such fields are _displayed_, i.e. if the user chooses:
- '|' then fields are shown as artist1|artist2
- ' | ' then fields are shown as artist1 | artist2

When the user enters the splitting character in a field that spacing is ignored. i.e. if the splitter is configured as ' | ' then whether the user enters artist1|artist2 OR artist1 |artist2 OR artist1| artist2, MM will display the field as artist1 | artist2

So the only change that I'd suggest would be to only allow a single splitter character + (optionally) the ' ' character (before and/or after) ?

3) As described above, such an option doesn't seem to be required as it's already implemented (the user just has to enter ' | ' as the splitter.

4) I think that the issues/confusion raised by LL is due to the fact that the The tooltip implies that only a single character is used. We might want to change it as indicated:
This specifies what character is used to denote multiple values within a single field (e.g. Rock;Folk).
-->
This specifies what character is used to enter multiple values within a single field (e.g. Rock;Folk) and spacing for how the values are displayed.

LL, if you agree, please re-assign to Michal for feedback.

lowlander

2021-10-13 18:07

developer   ~0065169

1) That works for me, it should only allow input that will actually be used:
1 ' |- ' is allowed as input, but only ' | ' is displayed
2 '; ' is allowed, but only 1 space is displayed

4) Tooltip is a good idea

5) It indicates a restart is required, none is offered when changing this setting. Also it seems to work as expected without restart, so is it really required?

michal

2021-10-14 13:01

developer   ~0065198

Fixed in build 2509. Restart note removed. Value is auto-adjusted after editing to not contain unsupported value (changing it during editing would be uncomfortable).

lowlander

2021-10-15 16:50

developer   ~0065230

1)
3 ';- ' is changed to ' ;' trailing space becomes leading space
4 There is no feedback to user that the entered value is incorrect. It would be better if there was feedback, and not just silent change. So either
A) a prompt that entered value is incorrect, only single separating character allowed, please fix
B) a prompt that only single separating character allowed, additional characters have been removed
C) Field turns red, with label next to it that multiple separating characters detected, please fix

4) I'm not sure that the tooltip really clarifies that a single separator character is allowed.

5) Fixed

michal

2021-10-15 16:56

developer   ~0065233

4) I would not complicate things for such simple setting (MM4 also changes used separator silently). What about simple toast message of type B? I did not used it yet, as we do not have such strings, but if this wording is ok, I can add it.

michal

2021-10-15 17:01

developer   ~0065235

3) fixed in build 2510.

rusty

2021-10-15 19:54

administrator   ~0065242

1) I agree that it's overkill--afaik we haven't had many complaints/confusion about this (and MM5 already improves this over MM4)

4) How about the following tooltip:

This specifies a single character used to enter multiple values within a field (e.g. Rock;Folk). Spaces determine how the character is displayed.

lowlander

2021-10-21 20:34

developer   ~0065397

4) That works much better.

michal

2021-10-22 06:39

developer   ~0065409

Tooltip wording fixed in build 2512.

lowlander

2021-10-28 22:37

developer   ~0065536

Verified on 2512