View Issue Details

IDProjectCategoryView StatusLast Update
0017957MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-11-24 15:56
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.1 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017957: Auto-tag fails to match tracks to a single release of an album
DescriptionWhen attempting to Auto-tag The Beach Boys - Pet Sounds album (13 tracks / 1966), MM (build 5.0.1.2410) correctly associates each of the tracks with Pet Sounds, but it matches the tracks to different _releases_ of Pet Sounds resulting in:
1) Incorrect track numbers (tracks should be 1-13, instead some tracks are # 15 , 17)
2) Tracks with different Years/Dates

MM should match tracks to a single release of an album (based on the first instance + the number of tracks), and only if it can't, should it assign tracks to different releases of the album.
TagsNo tags attached.
Fixed in build2522

Relationships

related to 0018435 closedpetr Auto-tag: Date field doesn't appear even when it has been found / apply Album Date preferentially 
related to 0018573 assignedpetr Auto-tag: often fails for tracks with an apostrophe in the title 
related to 0018574 closedpetr Auto-tag: overlooks album releases for which tracks don't have time metadata 

Activities

rusty

2021-05-31 16:13

administrator  

petr

2021-06-04 12:36

developer   ~0063746

item 1) fixed

petr

2021-06-07 18:43

developer   ~0063799

item 2) i know where the problem is, but it's high regression risk to fix it now ... this issue is related just to albums with several releases released during years with same names.

jiri

2021-11-15 08:37

administrator   ~0065929

Per IM with Petr, we'll try to choose the best release by assigning points to each release and then using the one with most points (aka 'the winner'). Points could be issued like this:
a. For each track found in the MB release (20 points).
b. For each track having the same length in user's DB and MB (+/- ~2 seconds) (1 point).
c. For each track with the same track # in user's DB and MB (1 point).
d. Subtract the difference of track count in user's DB and MB release (-n points).

petr

2021-11-15 11:03

developer   ~0065930

Fixed

lowlander

2021-11-16 20:57

developer   ~0065951

Verified on 2520 for the Pet Sounds Album, all files associated with the same Album. However for the Time Of My Life Album from 3 Doors Down it incorrectly associates all but 1 file with the deluxe Album: https://musicbrainz.org/release/03474923-1ecf-4a2a-b481-b119052a05c0
image.png (358,346 bytes)

petr

2021-11-17 14:50

developer   ~0065969

FIxed

lowlander

2021-11-18 20:39

developer   ~0065986

Unfortunately track 8 is still associated to the correct Album, while all other tracks are associated with the deluxe version of the Album

rusty

2021-11-18 21:33

administrator   ~0065991

Last edited: 2021-11-19 00:04

3) Also, I tested this with the Pet Sounds album, and now it always returns the 2016 version of the album instead of the 1966 version. MM is supposed to preferentially suggest (or at the very least, display) the earliest instance of an album when there are multiple releases of it.

Note: can you clarify whether the implementation suggested at 0017957:0065929 replaces the heuristics previously implemented? e.g.
- Are Albums given preference to singles? Are we still giving preference to the earliest release of an album?
- Are Compilation Albums filtered out (unless no other option exists) when the compilation flag isn't enabled?
- If the compilations option is enabled, does MM give still preference to non-compilation sources?
etc...

jiri

2021-11-19 08:37

administrator   ~0065999

Last edited: 2021-11-19 15:31

Ok, this wasn't included in the proposed rating system of a release. I'd say that in case tracks already have release date in tags, then we should add ~ 50 points to a release having the same year (or +/-1?) and in case there isn't such a match, we'd add probably something like (2020-year) points.

peke

2021-11-19 22:20

developer   ~0066008

Last edited: 2021-11-19 22:29

First results of my requested tests for specific tracks:

4) "The Tracks of My Tears by Smokey Robinson & The Miracles" do not listed 'Tears of a Clown' in results at all but for me track was "Tracks of My Tears by Smokey Robinson & The Miracles" and Tags were already correct pointing to album https://musicbrainz.org/release/0080b6e9-eb79-4c93-b024-d4c3a42c07ae which was also not listed in results. EDIT: MM4 with Discogs plugin find it in first try under https://www.discogs.com/release/7483691-Various-100-Hits-Movies

5) I am able to replicate both correct and incorrect results (tracks sent to Petr for analyze)

Based on these specific cases looks like special characters make big difference in results eg. ', :, &, -, ...
Note: When Tag from filename then often - in Album name is actually : which can't be used in folder/filenames
Smokey.png (58,611 bytes)   
Smokey.png (58,611 bytes)   
Jett.png (159,951 bytes)   
Jett.png (159,951 bytes)   

petr

2021-11-20 21:31

developer   ~0066012

Last edited: 2021-11-20 22:23

re 10) it's because track in Soul Men album is named 'Soul Men' ... and track title is originally tagged as 'Soul Man' ... for this reason it choose album with track named same as track title
re 11) for me it was detected correctly and set date to 1.1.1961
re 12) Length of the Ramblin' Man on Brothers and Sisters is 4:48 ... your track is 5:00 ... that's the reason why it wasn't assigned to this album

rusty

2021-11-21 00:16

administrator   ~0066017

Last edited: 2021-11-21 17:32

So to summarize the current status re lookup issues:
- Petr indicated that issues 4, 5, 11 are working correctly, but per my test results they aren't. Could it be that build 2522 is different than what you're running locally? Or are the results now non-deterministic?
- Issue 7) is still outstanding
- Re. issue 12) : would it make sense to expand from +/- 2 seconds to +/- 3 seconds (I know that it wouldn't solve this issue, but it would likely help in other cases). Or perhaps in the points scale deduct 10% from the multiplier for each second off.

Issues 8) and 9) are unrelated to lookups. I've moved 8) to 0018567, and am retesting 9).

petr

2021-11-21 11:46

developer   ~0066018

Last edited: 2021-11-21 18:50

re 4, 5, 11) i've tried on 2522 i sent you with same results ... will add some debugging to see why you have different results than me
re 7) it's an issue here as well
 Paranoid by Palaye Royale wasn't found in MB and acoustID detected it as Paranoid by Baely (the only recomendation)
 Think about me by jxdn wasn't found in MB as well and acoustID detected it as Swing with me by Jessica Simpson ... and again that was only recomendation
re 12) it's 12 seconds difference

rusty

2021-11-22 15:30

administrator   ~0066026

Re. 4/5/11 - OK waiting for a test build.
Re. 7) Does the fingerprinting give a confidence interval associated with the recommendation? In these cases the original metadata was preferable to the recommendation so I wonder if there's some way to prevent such poor overwrites of existing metadata?
Re. 12) Yes we can't solve this particular issue. I'm just wondering if there are other cases in which a rip yields a track that's +/- > 2 seconds of the original and whether we should expand that limit slightly (or not).

petr

2021-11-22 17:21

developer   ~0066027

re 7) no, there's no confidence or score

rusty

2021-11-22 18:36

administrator   ~0066030

Last edited: 2021-11-22 18:39

13) When the setting 'For individual tracks, recommend albums instead of singles from the same time' is enabled, MM is recommending the single over the album. The album should be recommended even if the single was older--if the album was released within x months of the single (I believe x was set to 6 months?). e.g.
You should be sad by Halsey is found from 'You Should be Sad'/1/10/2020 instead of 'Manic'/1/17/2020

petr

2021-11-22 22:37

developer   ~0066040

Last edited: 2021-11-22 22:39

7) we have an algorithm to detect what's the correct recording from the recordings set received from fingerprint server (acoustID) ... it's based on title, artist, track length etc.
13) fixed

rusty

2021-11-23 01:47

administrator   ~0066042

Last edited: 2021-11-23 21:34

4) No longer reproducible
13) Verified in 2522 testbuild c
----------------------------------------------------

The following issues remain:

5) a) I love Rock 'n Roll - it's an issue related to the apostrophe. Tracked at 0018573
 b) The Tracks of My Tears | Smokey Robinson . MM still recommends a recommends a recent compilation rather than the original 1965 or later 1967 albums. One good point: clicking 'find more albums' finds the 'Going to a go-go'|1965 album. Do we know what the issue is?
Note: build 2519 didn't recommend the correct album either (i.e. it's not a regression).

7) This problem still occurs. i.e. when existing track title metadata cannot be located in the MB database, MM uses a fingerprint to generate the lookup which sometimes results in overwriting good metadata with bad metadata. As indicated by Petr, we have an approach that tries to deal with this, but we should figure out a way to better prevent this (if not now, in the future).
Note also that it is a regression for the track by jxdn--in build 2519 and earlier MM5 did _not_ recommend the incorrect track.

10) This issue is still open. i.e. 'Soul Man' is recommended a 2017 album and the earliest choice is a 1993 album. Petr indicate that this is related to the fact that the associated correct album had a similar but not identical AlbumName (Soul Men), but I don't understand why this would matter. These releases exist in Musicbrainz and are correct:
https://musicbrainz.org/release-group/e5d26a1a-9da9-3f3d-8fcb-730aec1bd4d8

11) Tracked at 0018574

12) I'm still wondering whether we should make a change so that tracks that are closer in length aren't completely rejected. e.g. raise the confidence score the closer the time is to the actual track

14) This is quite similar to 12; Follow me Around | Radiohead 5:26. Autotag finds it on 'Follow Me Around' instead of 'Kid a mnesia'. The timing is off by a small amount, but considering that the album contains the instance of that recording that is closer to 5:26 than any other, shouldn't MM have recommended it? OR at least listed it as an option?!
Note: build 2519 and earlier recommended 'Meeting People is easy' a compilation from 2000 that has a different version of the song. i.e. it was also incorrect so this technically isn't a regression.

petr

2021-11-23 16:39

developer   ~0066053

Last edited: 2021-11-23 20:59

14) fixed

EDIT by Rusty: 10) is also fixed

rusty

2021-11-23 20:31

administrator   ~0066058

Last edited: 2021-11-23 20:51

15) Similar to 14, but actually caused by our current heuristics

Lykke Li | Get Some 3:24 returns 'Get Some'/10/25/2010

instead of the album 'Wounded Rhyme'/2/2/2011 released 3 months later.
https://musicbrainz.org/release/79383d7d-9aa7-438d-989b-e6d6be416cf5

Petr indicated that this is because our current rules only prioritize the album if it was released within a month of the single. Per discussion, we should change this to 4 months (and possibly make it user-configurable in the future).

petr

2021-11-23 22:28

developer   ~0066060

15) fixed

rusty

2021-11-23 22:31

administrator   ~0066061

14) On further investigation the reason 'Kid A Mnesia' isn't recommended is because it's considered a Compilation. And if 'Allow Compilations', is enabled, MM recommends the Soundtrack 'Meeting People is Easy' because a higher score is assigned based on it being older, even though the version on that album
https://musicbrainz.org/release/5a8fcf4f-5f6e-47b8-8e89-60aade86c69c - is 3:30
vs
https://musicbrainz.org/release/ec046815-c5d4-4943-b336-0b83aefde154 - is 5:19
This can be optimized in the future.

15) This has been fixed in the latest build of 2522.

rusty

2021-11-23 22:35

administrator   ~0066062

Marking this as fixed in order to trigger testing. The initial issue has been solved, and regressions seem to be mostly fixed along with several issues that weren't regressions.

I'll open new bugs for any of the remaining unresolved items.

rusty

2021-11-24 05:50

administrator   ~0066070

Last edited: 2021-11-24 15:56

Tested all of the previous test cases. The only ones that remain open that haven't already been moved to new bugs are:
5) b) The Tracks of My Tears | Smokey Robinson . MM still recommends a recommends a recent compilation rather than the original 1965 or later 1967 albums. One good point: clicking 'find more albums' finds the 'Going to a go-go'|1965 album. What's particularly strange is that 3 instances of the track yield different results. To be documented in a new bug.

7)

14)

16) I tested this on 150 tracks that had previously been auto-tagged and it resulted in numerous improvements (better album matches, metadata) except for the following minor issue -- Some dates changed to a year. e.g.
Agnes Obel | Aventine / Aventine / 9/30/2013 --> 2013
Circles | Post Malone / Hollywood's Bleeding / 9/6/2019 --> 2019
Dance Monkey | Tones and I / The Kids Are Coming / 11/22/2019 --> 2019

 --
Question:
12) Seems to be fixed in 2522. Is it supposed to be fixed? i.e. the track Ramblin' Man is 12s different from the version on the Ramblin' Man album so why is the album recognized now, but not previously?

--

Leaving as 'Resolved' until the remaining bugs are entered as new issues.