View Issue Details

IDProjectCategoryView StatusLast Update
0017905MediaMonkey 5Otherpublic2021-06-18 02:34
Reportermichal Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017905: Column filter is empty sometimes - regression
DescriptionAfter these steps Column filter lists are empty:
Steps To Reproduce1) go to Music - Artists (Grid) or Albums (Grid)
2) switch Column filter on
-> it opens empty
TagsNo tags attached.
Fixed in build2408

Activities

michal

2021-05-22 11:31

developer   ~0063393

Fixed in build 2408.

michal

2021-05-27 19:51

developer   ~0063561

I am not sure, if we could avoid reloading, due to how filtering works, these actions set new data source and it leads to grid reload. Anyway, I think it is really minor issue.

michal

2021-05-28 12:31

developer   ~0063589

We cannot reproduce the crash, no crash report arrived, and the log does not show any crash (except error 14D1FC2F at the beginning, fixed in the last build). Please try to retest with the latest build and eventually send me also crash report.

lowlander

2021-05-31 23:55

developer   ~0063645

This may be a minor issue on a small Library, however on a large Library merely enabling/disabling the Column Filter (which doesn't filter anything, the filelist hasn't changed) takes 10+ seconds each time.

michal

2021-06-01 11:28

developer   ~0063658

Last edited: 2021-06-01 11:29

View 2 revisions

Enabling filter lasts long (especially the first), because it needs to analyze whole extremely long tracklist and extract filter values from it, this cannot be skipped, disabling it is quite quick even with 1.3GB database on my PC.

lowlander

2021-06-18 02:34

developer   ~0063991

Closed on 2417

Won't fix Grid reloading when enabling/disabling Column Filter