View Issue Details

IDProjectCategoryView StatusLast Update
0017881MediaMonkey 5Collectionspublic2021-09-22 20:19
ReporterLudek Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
Product Version5.0 
Target Version5.1Fixed in Version5.0.2 
Summary0017881: Collection is shown as 'Disabled' even when it is visible
Description1) Go to Options > Collections & Views
2) Add new collection and uncheck the checkbox in the collections list twice to make it disabled, click [OK] in Options
=> collection isn't visible as expected
3) Go to Options > Collections & Views again and check the collection's checkbox to make it enabled, click [OK] in Options
=> collection is shown in the media tree as expected
4) Right-click the collection in the Media Tree and select 'Edit collection...'
=> 'Collection Options' dialog is shown, but on the third row there is:
Visibility: [Disabled] (unexpected) , should be 'Visible always'
5) Click [OK]
=> collection disappears
TagsNo tags attached.
Fixed in build2503

Relationships

related to 0016864 closedpetr Root views are not Refreshed on Scanning 
related to 0018282 closedlowlander "Visible if content exists" doesn't work for "Podcasts" node? 

Activities

Ludek

2021-09-15 13:34

developer   ~0064647

Fixed in 5.0.2.2503 by the same fix as 0018282

peke

2021-09-17 23:23

developer   ~0064742

Verified 2503

All settings are persistent.

Ludek

2021-09-22 17:24

developer   ~0064825

Last edited: 2021-09-22 20:19

View 3 revisions

OK, on LowLander's database I can replicate the several seconds delays between updating the tree with the settings applied in Options > Media Tree.

To be improved...

EDIT: The performance leaks caused by fixing 0016864

EDIT2: Made some improvements in 2505, but still more to do...