View Issue Details

IDProjectCategoryView StatusLast Update
0017857MediaMonkey 5Now Playingpublic2022-01-16 21:41
Reporterrusty Assigned To 
PriorityhighSeveritymajorReproducibilitysometimes
Status closedResolutionunable to reproduce 
Product Version5.0 
Target Version5.0.1 
Summary0017857: Playing list status gets corrupted in some cases (resulting in MM crash)
DescriptionIf the user adds tracks to the Playing list by right-clicking on nodes, the Playing list eventually gets corrupted meaning that:
- the number of tracks that are shown as Playing is incorrect (it'll show 700 even if there are only 5)
- the number of tracks that are shown fails to update
- MM will sometimes crash on close

To replicate:
1 right-click Genre1 > Play Now
2 right-click Genre2 > Play Next
3 right-click Genre3 > Play Next
4 right-click Genre1 > Play Now
--> 7 tracks appear in the Now Playing list even though it indicates that there are 727

I'm no longer able to replicate the issue or generate a log of this, but I'm entering it nonetheless as I submitted several crashlogs that occurred on closing MM after this occurred between 9:30pm and 10:40pm on 5/12. Please assign back to me if there's nothing useful.
TagsNo tags attached.
Fixed in build

Activities

Ludek

2021-05-13 10:48

developer   ~0063179

I cannot replicate, and the only crash from Rusty here is 1CEA0526 that rather shows a crash while sending report (without an information why the report was initiated).

Assigned to Michal to try to replciate and verify related code.

michal

2021-05-13 12:13

developer   ~0063181

Reproduced once problem with state info updating of Playing list, happened after calling Play now from media tree on some genre (with Show all subnodes on). Once it happened, the state info of playing list had wrong number of tracks (but no crashes)

michal

2021-05-13 15:30

developer   ~0063187

I cannot reproduce it more, tried many times. Please try to find the way how to reproduce it more consistently. It seems to be some special timing with maybe some specific steps needed before.

rusty

2021-05-20 00:48

administrator   ~0063304

Last edited: 2021-05-20 02:09

View 2 revisions

Reduced priority as I'm unable to replicate. Peke please see if you can.

peke

2021-05-20 10:52

developer   ~0063316

Tried multiple times including stressing now playing with 10k+ tracks addition/deletion and insertions. I can't reproduce it either in 2405 so only thing we can do is to Resolve it for now.

peke

2021-05-20 18:47

developer   ~0063334

As agreed offline closing, no one can replicate.