View Issue Details

IDProjectCategoryView StatusLast Update
0017795MediaMonkey 5Track Browserpublic2021-07-06 20:23
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017795: Preview [Selected] fails to update in List (by album) views
DescriptionIf the user selects all tracks on an album by clicking the Album Art in the 'List (by album' view
-->
all tracks in the album are selected, and the Preview [Selected] window fails to update. This is especially confusing because:
- selecting multiple tracks on the album doesn't exhibit the same behavior (i.e. when selecting multiple tracks manually Preview only shows the last selected track, but when selecting multiple tracks by clicking the AA image Preview fails to update)
- the issue occurs even when selecting an album that contains only a single track

To fix:
1) When clicking an album art image for an album with a single track, there's no reason for the Preview window not to update. Should be fixed.
2) When clicking an album art image for an album containing multiple tracks and/or when selecting multiple tracks, MM should usually update the Preview window, and ideally exhibit similar behaviour regardless of how the multiple tracks were selected. Either:
a) change the approach used for selection when the artwork image is clicked and select only the first track associated with the image. Upside: simple fix. Downside: no longer trivial to select all tracks on the album (though user can easily click the Album Summary and then CTRL-A instead); also this doesn't fix the inconsistency re. the Preview window's response to multi-track selection.

b) Retain the current approach to selection (i.e. Clicking AA --> multiple tracks are selected), but have the preview window only show Artwork/Metadata for the first track). Upside: simple fix and is quite similar to how manual multi-track selection works. Downside: Users can be confused as to which track(s) are being represented/edited in the Preview window especially in cases where only album metadata/artwork is displayed.

c) Take the approach described in b) but, when multiple tracks are selected (regardless of how), modify the Preview window behiour so that in cases where multiple tracks are selected it shows the associated artwork for the first track IFF all tracks are from the same Album and have the same artwork (i.e. same Album/Album Artist/Year/Album Art). Upside: track art/metadata displays in most cases and there's less confusion about which tracks are being represented since tracks spanning different albums just aren't shown. Downside: for compilation albums with per-track artwork, the track metadata & artwork won't display.

I think that 2b might be the best approach for now, and that we can later decide whether 2c is needed or not.
Additional InformationRaised at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98897
TagsNo tags attached.
Fixed in build2402

Relationships

related to 0016371 assignedLudek Switching views expands / changes selection 
related to 0017787 newLudek Preview [Selected] fails to update when switching to a new tab that should display a blank preview 

Activities

petr

2021-05-06 15:15

developer   ~0063072

Fixed

rusty

2021-05-10 00:15

administrator   ~0063111

Verified 2402.