View Issue Details

IDProjectCategoryView StatusLast Update
0017782MediaMonkey 5FileMonitor / Find Missingpublic2021-05-05 11:49
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017782: Scanning - Continuous doesn't work (regression 5.0)
DescriptionIf the user enables Scanning (Continuous) for a directory, then MediaMonkey 5 fails to recognize tag updates made to files in the directory. In addition, scanning settings are lost on restart.

To replicate:
1 Set MM5 to continuously monitor Music/Album X
2 Navigate to Music > Albums > Album X [album view]
3 In another program, change the artist metadata of one of the tracks in Album X
--> MediaMonkey fails to display the change!
4 Press F5
--> MediaMonkey fails to display the change!
5 Press INS to manually initiate a scan of the directory
--> MediaMonkey displays the change
6 Restart MediaMonkey
7 Press INS
--> Scan settings show the scan settings for Music/Album X as 'Manual' rather than 'Continous'!
So there may be 2 separate bugs (lost config setting / failed continuous scan) or just a failure to save the config which results in the failed continuous scan.

This is a regression vs MediaMonkey 4 which is working correctly in my environment for the same usecase.
Additional InformationTesting of this issue was triggered by the report at, though it appears to be unrelated:
https://www.mediamonkey.com/forum/viewtopic.php?f=27&t=98878
TagsNo tags attached.
Fixed in build2400

Activities

Ludek

2021-04-25 20:39

developer   ~0062913

Last edited: 2021-04-25 21:00

View 3 revisions

Tried briefly and I can't replicate the settings not persisting issue, but I can replicate that the tag metadata updated externaly does not update in MM5 (even if I see the file monitor working and updating it in the debug log), but in my case they don't update even after manual re-scan. Probably a ID3 version mismatch or something like this, I'll investigate this more deeply tomorrow...

EDIT: OK, in my case it did not work because I had disabled the checkbox in 'Options > Library > [x] Update info from tags when rescanning files'
Once I enabled the checkbox then it started to work, i.e. using F5 in MM5 > Music > Location > ... does show the new values.
Note though that I used MM4 for the tag modification, I'll try with the Mp3Tag app tomorrow...

Ludek

2021-04-26 11:20

developer   ~0062919

There were actually three issues:

1) Folder's settings to "Continuously" was applied only once MM5 was restarted (should be applied immediatelly after clicking [Save] or [Scan now] in the Add/Rescan dialog)
2) Folder's settings to "Continuously" sometimes failed to save/store on MM5 closing -- thus not restored after MM5 restart => the Rusty's case
3) Metadata changes in tags were updated in the view only after pressing F5 (to refresh)

All three issues are fixed in 5.0.1.2400

peke

2021-04-29 00:12

developer   ~0062966

Verified 2400

Confirm all three cases fixed, I also tested regression, but it would be good to see second verification before closing.

Ludek

2021-05-05 11:49

developer   ~0063051

Also confirmed by user here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98958

Closing...