View Issue Details

IDProjectCategoryView StatusLast Update
0017781MediaMonkey 5Syncpublic2021-05-25 10:13
ReporterLudek Assigned To 
PriorityimmediateSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017781: Crash 19F86866 on Wi-Fi sync (regression 2334)
DescriptionUser at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98872
reported a crash during Wi-Fi sync.

Based on the crash log it looks like a regression while fixing the leaking prepared queries (issue 0017755 )

As for the steps to reproduce: Based on the crash log this can happen during the initial pairing process (when there are some pre-uploaded tracks in MMA that needs to be paired with MM5 tracks)
TagsNo tags attached.
Fixed in build2400

Relationships

related to 0017755 closedLudek Memory leak while casting to DLNA client 
has duplicate 0017918 closedLudek Sync: When Initial profile gets created in MMA over WIFi MM5 crashes 

Activities

Ludek

2021-04-23 09:47

developer   ~0062906

Last edited: 2021-04-23 10:37

View 3 revisions

Test notes: The issue is a little bit tricky to replicate as it appears only when there is at least 100 "unpaired" tracks.
The initial pairing process between MMA and MM5 happens typicaly when MM5 instance is changed.

So in scenario like this:
- having 150 track in MMA
- clean install of 2236 (or deleted MM5.DB so that it creates fresh library)
- select new sync server in MMA (the new MM5 instance) and initiate wifi-sync to force pairing the tracks
=> first batch of 100 tracks is paired correctly
=> it crashes on the second batch and thus leaving 50 tracks unpaired
- restart MM5 and sync again
=> no crash as the remaining 50 songs has been paired in the first batch

So if you have e.g. 320 unpaired tracks in MMA then MM5 (2336-2338) will crash three times for you, then the Wi-Fi sync will start to work.

Ludek

2021-04-23 12:02

developer   ~0062908

Last edited: 2021-04-23 12:07

View 3 revisions

Low risk fix of this crash added to SVN (revision 37866) -- could be merged to 5.0.0 as a "hot fix"

But they are more general (possible) problems related to prepared queries used in external threads -- to be fixed for 5.0.1.2400

Ludek

2021-04-26 08:35

developer   ~0062918

Last edited: 2021-04-26 09:08

View 2 revisions

More general fix for prepared queries used in external threads added in 5.0.1.2400 (SVN revision 37870).

peke

2021-04-29 00:14

developer   ~0062967

Verified 2400

Unable to replicate, looks it is working now.

Test note: Tested for regression when doing same pairing with multiple devices simultaneously.