View Issue Details

IDProjectCategoryView StatusLast Update
0017726MediaMonkey 5Codecspublic2021-04-16 14:43
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017726: Files with Path >300 Chars fail to play and read Album art when browsed with MM
Description1. I can't play or D&D FLAC files from explorer that have >300 char path

Tested file path of 360 chars "\\192.168.1.250\Download\transmission\completed\!!!SerijeDownload\!!!!!Serije Nesredjene\Benjamin Shaw - Exciting Opportunities- A Collection of Singles and Sadness\Benjamin Shaw - Exciting Opportunities- A Collection of Singles and Sadness\Benjamin Shaw - Exciting Opportunities- A Collection of Singles and Sadness - 07 The Birds Chirp & the Sun Shines.flac"

2. MP3 file in same folder plays normally when D&D from Explorer (Looks like explorer Shorten Filename to 8+3), but if using MM Folder browser they can't be played

3. If last path when MM was closed is >256 Chars long then No track info is read on MM restart, but you need to go back folders till it is <256 and then files Tags are read (excluding Album Art)

Definicion for UNC paths format both local and and network https://en.wikipedia.org/wiki/Path_(computing)#Universal_Naming_Convention
TagsNo tags attached.
Fixed in build2333

Relationships

related to 0016791 closedmichal Remove ID3V1 & V2 from FLAC can fail (AV) 
related to 0015572 closedmichal Possible EPathTooLongException when ripping CDs 
related to 0012868 closedmichal Ability to support long filepaths (> 260 chars) on Windows 
related to 0017724 closedmichal Files with unset attributes can't be tagged or organized (regression) 

Activities

rusty

2021-04-06 17:26

administrator   ~0062702

Last edited: 2021-04-06 17:29

View 2 revisions

Note: Peke indicated that the problematic files have the 'a' attribute set, which would imply that this issue is independent of 0017724

peke

2021-04-06 19:16

developer   ~0062704

Attributes of Files from supplied album I have used in test.

NOTE: I never received non accessible dialog in all of my tests.

michal

2021-04-07 09:03

developer   ~0062719

Problem is caused but the fact, that Windows API function "GetFileAttributesW" fails when accessing long paths like this. It is used on many places, e.g. when checking accessibility or existence of the file, it is also called from some Delphi system functions. It works for local files ( with prefix "\\?\" we automatically use), but for paths like "\\address\...\" fails in case path is longer. I am not sure, if we could find some workaround, it seems to be Windows API bug. I tried VLC and it fails exactly the same way.

michal

2021-04-07 09:50

developer   ~0062720

Drag and drop from Explorer works, because Explorer automatically convert the long path to 8.3 notation like: \\192.168.1.250\Download\TRANSM~1\COMPLE~1\!!!SER~1\!!!!!S~1\BENJAM~1\BENJAM~1\BEC781~1.FLA
But this won't work in situation, where user has creating 8.3 filenames turned off for NTFS partition. Also this short path is sometimes created incorrectly and does not work too (it can destroy file extension), so such solution is also not very reliable.

Ludek

2021-04-07 11:34

developer   ~0062721

I think that \\?\UNC\' prefix might work, Michal is trying...

michal

2021-04-07 12:21

developer   ~0062722

Fixed in build 2333. Prefix '\\?\UNC\' for such addresses works.

peke

2021-04-07 21:36

developer   ~0062738

Verified 2333

Works now. Tested on Paths up to 860 chars and containing Cyrillic characters.