View Issue Details

IDProjectCategoryView StatusLast Update
0017587MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-02-26 18:41
Reporterdrakinite Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017587: Image Search for Artists: "Default Icon" causes artist icon to disappear entirely
DescriptionAfter peeking into the database, it looks like setting "Default Icon" causes the PictureDataHash attribute, under the Artists table, to be set to "_icon". I believe that this error is what causes the artist initials to appear instead of the randomly selected album art, which is in fact the default.

On my own database, clearing "_icon" from PictureDataHash caused the correct icons to once again appear.
TagsNo tags attached.
Fixed in build2315

Relationships

related to 0013988 closedpetr Add possibility to set artist image chosen from user HDD. 
related to 0017031 closedLudek Add album collage for artists with missing images 
child of 0016473 feedbackrusty Album art: Possibility of assigning different album art per track for Compilation Albums 

Activities

drakinite

2021-02-21 00:51

developer  

image.png (6,079 bytes)   
image.png (6,079 bytes)   

Ludek

2021-02-21 17:54

developer   ~0062073

I see that the [Default icon] ('_icon' in the pictureDataHash) was added by Michal in SVN revision 28073: 0013988: Add possibility to set artist image chosen from user HDD. - finished new find image dialog

It looks like it might be intentional -- to be able to set icon for artists/playlists/albums where user really wish to always see icon -- and not the automatically looked up (or assigned image/collation) ??

michal

2021-02-21 18:03

developer   ~0062074

It is by design, "Default icon" sets this special value, which causes, that artist icon displays default "no image" icon and not use automatic lookup. User can set it, when auto lookup e.g. always finds and assign wrong image for some artist.

Ludek

2021-02-21 18:06

developer   ~0062075

Draki probably means the fact that currently it is impossible to get back from incorrectly looked up image to the default collage (0017031)

Ludek

2021-02-21 18:16

developer   ~0062076

Fixed in 2315.

i.e. reverting to the [Default icon] will show the default collage (0017031) or the default icon (when there isn't any collage).

Ludek

2021-02-21 18:43

developer   ~0062077

Last edited: 2021-02-21 18:47

View 4 revisions

Re-opened:
Line 1794 in templates.js -- if (item.itemImageType === 'icon') { path = '-';
is still causing that only the icon is shown (and not the collage).

Assinged to Michal to review whether it is safe to change the bahaviour (especially re auto image lookups)

michal

2021-02-22 11:56

developer   ~0062086

Fixed

peke

2021-02-25 23:51

developer   ~0062145

Reopen It does not reset to default Icon if Artist have albums and Artist image was already added from one of albums, while there was not enough Album Arts to create Collage even there is enough albums and their Album Arts are fetched with Auto Lookup.

peke

2021-02-26 00:04

developer   ~0062147

Another way to replicate is taht if there is an collage on Artist Lookup image and then selecting Default Icon do nothing.

michal

2021-02-26 07:30

developer   ~0062153

Note - because of 0017031 "Default Icon" means collage from album artworks and only in case, there are no artworks, display icon. So when collage is made from one artwork, it could look, like nothing changed, it is expected.
I will look at resetting collage.

rusty

2021-02-26 14:04

administrator   ~0062158

Leaving with Michal to triage.

michal

2021-02-26 14:54

developer   ~0062161

Resolving, it is not bug. Collage can be done only from 1, 4 or 9 artworks from different albums, Peke had only 3 (the 4th was unsaved suggested artwork only), so the collage was created from one album. I have tested it and once Artists has at least 4 albums with artwork, it creates 4-image collage after choosing "Default icon".

peke

2021-02-26 18:41

developer   ~0062163

Thx Michal.

Verified 2315