View Issue Details

IDProjectCategoryView StatusLast Update
0017583MediaMonkey 5Main Panelpublic2021-12-10 02:31
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017583: MM Interferes with Automatically hidden taskbar [regression]
DescriptionIf the user has enabled Windows' "Automatically hide the taskbar' setting then MM blocks the functionality from working!

1 In Windows Taskbar settings, enable 'Automatically hide the taskbar in Desktop mode'
2 Maximize MM5
3 Move the cursor to the bottom of the screen
--> Taskbar fails to open!

In contrast maximizing other apps doesn't interfere with the Windows taskbar opening.

Note: I tested with a standard taskbar at the bottom of the screen, but user reported that the issue also occurs when the taskbar is at the left side.
Additional InformationReported at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93707
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=99669
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=100395
Ticket 2686
TagsNo tags attached.
Fixed in build2527

Relationships

related to 0018622 feedbackpetr MediaMonkey opens out of focus in some cases 

Activities

petr

2021-03-01 20:53

developer   ~0062185

Fixed

peke

2021-03-03 15:45

developer   ~0062205

Last edited: 2021-03-03 15:50

View 2 revisions

Reopen Still able to replicate in 2317

It partially works:
1. Set Taskbar to not hide
2. Maximize MM5
3. Set taskbar to hide
4. MM5 resizes and normally works/shows when you move mouse to bottom of desktop
5. Restor non maximized MM window -> Maximize again
6. Taskbar do not Show when you move mouse.

rusty

2021-03-03 15:58

administrator   ~0062207

I can replicate even more easily:
1 Set Taskbar to hide
2 Run MM5, maximize, move cursor to taskbar
--> fails to open
3 Run firefox, maximize, move cursor to tasbar
--> taskbar opens

rusty

2021-03-03 17:43

administrator   ~0062217

The workaround is to reboot the machine (restarting explorer.exe can solve the problems, but it can have the side effect of temporarily losing items from the system tray).

Pushing to 5.0.1, since a complete fix isn't obvious.

peke

2021-03-13 18:58

developer   ~0062433

Verified 2317-2324

This happened only that time and I could not replicate anymore in any version as of 2317-2324

lowlander

2021-05-15 16:09

developer   ~0063216

On build 2404 this issue is present. With MediaMonkey maximized the hidden Taskbar won't show when mousing at the bottom of the screen. This isn't a problem in other maximized applications

petr

2021-05-17 11:39

developer   ~0063240

I'm also not able to replicate. Do you have enabled 'MediaMonkey Player' toolbar in system taskbar ?

lowlander

2021-05-25 20:49

developer   ~0063480

It's still present on 2407 Portable. However it seems to require some very specific steps as it happened the first time tested, but have not been able to reproduce since.

rusty

2021-12-02 22:32

administrator   ~0066226

I'm able to replicate this consistently:
1 Enable auto-hide in desktop mode
2 Maximize MM to fill the entire desktop
--> the hidden taskbar doesn't appear!

Raising priority for 5.0.2 re-examination/triage.

petr

2021-12-08 09:13

developer   ~0066283

I've found out this issue also for Brackets, but not for Spotify (both are chromium apps).

petr

2021-12-08 13:04

developer   ~0066285

Fixed

rusty

2021-12-08 23:09

administrator   ~0066304

Last edited: 2021-12-08 23:10

View 2 revisions

I tested 2526 (portable) and it doesn't fix the issue.
0 Enable 'Automatically hide the taskbar in desktop mode'
1 Launch MM5 on right side of screen
2 Around line 9700 access the hidden toolbar via the left margin
--> it works
3 Line 9013 Maximize MM and access the toolbar
--> it doesn't open

Note:
- Results are the same with the Non-debug version (tested in Portable mode).
- Other apps work as expected

peke

2021-12-08 23:58

developer   ~0066308

Last edited: 2021-12-09 00:21

View 4 revisions

I can confirm only with different steps.

1 Maximize MM5
2 In Windows Taskbar settings, enable 'Automatically hide the taskbar in Desktop mode'
3 Minimize MM5
4 Maximize MM5
5 Move the cursor to the bottom of the screen
--> Taskbar fails to open!

MM5 Window have Always On Top Flag and is exact size of Screen even Start menu do noit work (short press of WIN Key).

Found out that many other apps do not work either. Waterfox, Camtasia, Total Commander, ... it is somehow started to behave after I resized taskbar to two lines of icons (unlock taskbar). Restart of PC fixed the issue. Also Noticed that working apps have 1920x1199 Resolution when maximized instead of 1920x1200

petr

2021-12-09 22:12

developer   ~0066322

Fixed

rusty

2021-12-09 23:02

administrator   ~0066323

Verified 2526 testbuild.

lowlander

2021-12-09 23:48

developer   ~0066329

Tried with it with Visualization and Playing (Album Art) to full screen and in neither did the Taskbar show (when set to automatically hide) when cursor is moved to the bottom of the screen.

peke

2021-12-09 23:58

developer   ~0066332

Verified 2527

For me it works OK and Fullscreen do not show which is as expected.

lowlander

2021-12-10 00:05

developer   ~0066334

Testing error, Maximized it works as expected.