View Issue Details

IDProjectCategoryView StatusLast Update
0017573MediaMonkey 5Conversion/Levelingpublic2022-04-29 22:57
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0017573: Volume analysis error flow is confusing
DescriptionWhen the user:
1 initiates volume analysis for a track that can't be analysed
-->Timed Error dialog appears for the track that can't be analyzed:
There was a problem analyzing volume for the following tracks:
....list of tracks....
[Continue] [Cancel]

2 Press [Cancel] (or [Continue] if only a single track is being analyzed)
--> Summary dialog appears that's near identical to the previous one:
There was a problem analyzing volume for the following tracks:
Retry
[ ] Track 1
[ ] Track 2
....
[OK]

see: https://www.screencast.com/t/TLtOzp7o4

The summary dialog is fine, but a more appropriate approach for the timed error dialog would be to use a Toast message each time an error occurs (as long as the toast stays in one place and doesn't flash multiple-toast messages). e.g.
Using existing strings:
Error: Volume analysis (<FileName>).
<Problem description>. . . . . . . . . . . . . . . . . . . [Cancel]

With new strings:
<FileName>: There was a problem analyzing volume. <Problem description> [Cancel]


Note: there's no need for a 'Continue' button with a timed dialog or a toast since that's the default behavior.
TagsNo tags attached.
Fixed in build2617

Relationships

related to 0017904 closedrusty Multiple dialogs when MM can't level files 

Activities

Ludek

2021-05-23 19:14

developer   ~0063404

Moving to 5.1 as it requires new strings and if we want to go this way (to change the timed error dialog to toast) then we should probably unify with all the others possible "timed error dialogs"
i.e. be it analyzing, volume leveling, ripping, file conversion, downloading, scanning, organizing ...

rusty

2021-10-15 16:52

administrator   ~0065231

Last edited: 2022-04-20 21:19

View 2 revisions

As proposed at 17904, we can use existing strings for the toast.

<CommandName> (error): <file> [Cancel...]

Note: I haven't reviewed the usecases of ripping, file conversion, downloading, scanning, organizing, etc. But yes, if other 'timed error dialogs' are duplicated with Summary dialogs, then we can probably use the same approach. Each of those usecases should be tested and a new bug created. But I suggest resolving the volume analysis 0017573 and volume 0017904 leveling issues for now.

BUT only if user interaction with the toast message isn't blocked by the high CPU utilization associated with the operation.

Ludek

2022-04-21 20:57

developer   ~0067663

Last edited: 2022-04-21 21:25

View 3 revisions

Fixed in 2617.

i.e. only the Summary dialog appears now and the duplicated "timed dialog" with Continue button no longer appears.

As for the need for a toast: Personally I don't think that the toast message is actually needed, it would be annoying anyhow IMO and probably user would fail to read it anyway (as the text would blink when there are many files in a row having trouble with the operation), so showing just the Summary of the operation with the list of failures is fine IMO.

rusty

2022-04-29 22:57

administrator   ~0067889

Verified while testing 0017904 on build 2618.

And yes, the current workflow seems to be fine without the toast messages.