View Issue Details

IDProjectCategoryView StatusLast Update
0017408MediaMonkey 5Main Panelpublic2021-01-20 23:28
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0 
Summary0017408: MiniPlayer: UI stops responding
DescriptionWhen playing video, I'm able to often get the MiniPlayer into a state in which it stops responding to the UI and the user must click the MediaMonkey icon in the taskbar > Restore in order to regain access to the MM UI. I haven't found a method that consistently triggers the problem, but it usually occurs when doing some combination of:
- Playing videos in the miniplayer
- Making changes to the Video window (minimize/close/maximize)
- Clicking controls in the miniplayer

Could this issue have the same root cause as the MicroPlayer failing to respond?
TagsNo tags attached.
Fixed in build2297

Relationships

related to 0017072 assignedpetr Micro Player: stops responding & other issues 
related to 0016523 closedpetr MiniPlayer: Tooltips lock the UI 

Activities

rusty

2021-01-20 17:11

administrator   ~0061470

Last edited: 2021-01-20 18:19

View 4 revisions

Note: further testing reveals that this bug can also be triggered without Video:
1 Play list of audio tracks
2 Minimize to miniplayer
3 Click AA to open 'Album Art' window
4 Close window
5 Click miniplayer Player controls a few times
--> UI is locked
Note: this doesn't occur consistently

EDIT: an hour later and I'm no longer able to replicate in this manner :-(

petr

2021-01-20 21:10

developer   ~0061479

Made some changes so please retest

rusty

2021-01-20 23:28

administrator   ~0061480

Unable to replicate in 2296, however, it's difficult to test since Video functionality has been disabled in the MiniPlayer. Holding off on closing until 0017421 is resolved.