View Issue Details

IDProjectCategoryView StatusLast Update
0017398MediaMonkey 5Install/Configpublic2021-01-18 21:55
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017398: 'Open with' and 'Default' apps can have multiple near-identical entries for 'MediaMonkey'
DescriptionAt 0017397:0061398, Drakinite brought up the issue that in the "Open With" menu, there can be duplicate listings titled 'MediaMonkey' with no way of distinguishing the two (and suggested that the portable version should be displayed as "MediaMonkey Portable" or "MediaMonkey (Portable)".

This issue can be subdivided into 2 issues:
a) MM4 vs MM5
b) MM 4/5 'normal' vs MM 4/5 'portable'

Re. issue a) it will be quite common (as MM5 installs will not, by default, remove MM4 installs) and even though the icons for MM4/MM5 differ slightly, most users will not realize the distinction. In addition, the problem also manifests itself in the Default Apps dialog, where the user will have the same challenge of having to figure out which 'MediaMonkey' is the right one. Given these issues, and given that in the start Menu, MM5 is identified as 'MediaMonkey 5', it should probably be identified as such in the 'Open with' & 'Default Apps' submenus.

Re. issue b) This is a far less common situation (in fact it likely will only affect testers) so I don't know that it's worth spending time on it.
TagsNo tags attached.
Fixed in build2295

Relationships

related to 0017397 newpetr Setting portable install of MM5 to open media files causes MM4 to open them instead 

Activities

petr

2021-01-17 22:04

developer   ~0061409

Fixed item a

rusty

2021-01-18 21:55

administrator   ~0061425

Verified in 2295, although the fix isn't quite what I'd expected. i.e. although a portable installation of MediaMonkey is now identified in the 'Open with' menu as 'MediaMonkey 5', it seems to be impossible to add multiple MediaMonkey instances to the 'Open with...' menu! i.e.
the issue described at 0017397 seems to be occurring even when _portable_ instances of MediaMonkey 4 and 5 are being used.