View Issue Details

IDProjectCategoryView StatusLast Update
0017359MediaMonkey 5Main Panelpublic2021-11-03 22:19
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017359: Average album rating is missing in album grids
DescriptionIn MM4 there was avarage album rating shown in "Show Art" views: https://www.dropbox.com/s/v4f6r897h1hmlsq/screenshot%202021-01-11%2016.50.15.png?dl=0

It is missing in MM 5.0: https://www.dropbox.com/s/wwexhlznz9wkkac/screenshot%202021-01-11%2016.52.14.png?dl=0

Requested at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98102
TagsNo tags attached.
Fixed in build2514

Relationships

related to 0018477 closedmichal Searching online crash with item.getRatingAsync is not function (regression 5.0.2) 

Activities

michal

2021-10-20 07:49

developer   ~0065349

Fixed in build 2511. I think we could consider have this optional, as it is quite demanding to display it in grid (many requests, many images in grid)

peke

2021-10-22 16:01

developer   ~0065439

Reopen we should increase space in Grid by few pixels (attached picture)

peke

2021-10-22 16:02

developer   ~0065440

bug17359.jpg (102,132 bytes)   
bug17359.jpg (102,132 bytes)   

michal

2021-10-22 17:28

developer   ~0065448

Resolving, it seems, it was some temporary problem with style files from older installation, not reproducible again.

lowlander

2021-10-22 18:28

developer   ~0065451

Verified that Ratings show for Albums.

Leaving open as scroll performance is really poor. The Option to enable/disable this is needed.

michal

2021-10-23 07:02

developer   ~0065466

As said before, grid scrolling generates bunch of debug messages (now even more with ratings), this affects performance extremely, please test performance always without DbgView.

lowlander

2021-11-01 19:48

developer   ~0065626

Verified, with DebugView closed the scrolling performance is much better.

However, the Rating isn't shown till scrolling is stopped, which is fine. The problem is that it shows the same no rating as when there is actually no rating. It would be useful if there was a indication that Rating is still being calculated/loading instead of using the no rating.

michal

2021-11-02 08:10

developer   ~0065633

Fixed in build 2514. Rating element is now hidden during reading and computing the value, so possible incorrect value is not shown during this time.

peke

2021-11-03 22:19

developer   ~0065691

Verified 2514

Works OK, No regressions found