View Issue Details

IDProjectCategoryView StatusLast Update
0017283MediaMonkey 5Extensions frameworkpublic2022-11-28 19:03
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.2Fixed in Version5.1 
Summary0017283: Addons: functionality is duplicated in 2 locations
DescriptionBug 0017143 seemed to initially be about adding the ability to configure installed addons from within the Options panel--just like other MediaMonkey functionality. However, it seems to have evolved into a complete duplicate of the functionality at Tools > Addons

It should be scaled down to meet the original requirements. i.e.
1) Don't show the addons node unless there's a configurable addon installed
2) Get rid of the 'Configure addons...' button. If any addons are configurable, they should appear in the tree (sub to addons)
3) Remove the 'Get more addons...' button

OR

We could move the addons functionality into the tree, and get rid of the option from the Tools menu. i.e.
1) Display addons directly within the addons node, and configurable addons as children in the tree (in this case, the 'Get more...' / 'Add' 'Find updates' functions would appear directly in the addons node at the bottom.
TagsNo tags attached.
Fixed in build2800

Relationships

related to 0017143 resolvedLudek Add dedicated Addons panel in dlgOptions 
related to 0013908 assignedLudek Extensions: Addons Site browsable directly from MMW 

Activities

drakinite

2021-02-11 17:09

developer   ~0061896

I believe the first option is best.
The original motive of 0017143 was for addon config panels to appear under the Addons category, and I believe that we did not make that change yet because we didn't want to make major tweaks before 5.0 release.
I agree with items 1, 2, and 3 as they make sense together. The Addons options category should only be visible when configurable addons are installed, and the only button it needs is a Manage Addons button. However:

4) we should add a tooltip to Manage Addons. Something like "This panel is for configurable addons. Click here to view, install, and delete addons."

Ludek

2021-10-06 17:24

developer   ~0065004

Per IM discussion there was an agreement that we don't want to have Addons within Media Tree.

Ludek

2022-11-28 18:51

developer   ~0070448

Last edited: 2022-11-28 19:03

OK, removed Addons from Options in build 2800 so that the functionality isn't duplicated in 2 locations + we have already the 'Configurable' filter in the Addons dialog.

One tweak I can think of is to show the configurable addons at first in the Addons dialog so that

1) users don't miss addons that can be configured
2) Configurable addons are easier accessible (no need to use the filter)

=> added the sorting in 2800