View Issue Details

IDProjectCategoryView StatusLast Update
0017276MediaMonkey 5Playlists (Auto) / Search / Filterspublic2021-10-22 18:15
Reporterlowlander Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017276: Search mode options counterintuitive
DescriptionHaving 'Respect Diacritics' (less flexible) combined with 'Match within words' (more flexible) seems counterintuitive. Also the option match within words would seem to counter the Search whole words only option.

I assume the search mode settings are set on speed instead of user search flexibility.
Steps To ReproduceIt might be better to have:

[Checkbox] Search Whole words
when disabled a sub-option dropdown becomes available:
  xx Matching beginning of words
  xx Match within words

Independent dropdown for:
 x Ignore diacritics
 x Respect diacritics
Additional InformationTODOC
https://www.mediamonkey.com/wiki/index.php?title=WebHelp:Search/5.0
TagsNo tags attached.
Fixed in build2511

Relationships

related to 0017395 resolvedLudek Respect diacritics breaks search operators 
related to 0005565 closedLudek Full-text search only finds prefixes (gives poor results in Oriental languages) 
related to 0018425 resolvedLudek Search mode options apply to contextual search but are configurable only for Global Search 

Activities

Ludek

2021-01-13 18:52

developer   ~0061313

You are right that combination of "Search whole words only" and "Match within words" does not make any sense.
I guess we should just hide (or disable) the "Search whole words only" checkbox whenever the "Match within words" is enabled, as actually it is ignored anyway.

Ludek

2021-01-13 18:57

developer   ~0061314

Last edited: 2021-01-13 19:00

View 5 revisions

ok, I refreshed the browser and seeing your new comments in "Steps to repro" section.
The problem is that currently we cannot ignore diacriticts and search within words as we are using FTS engine that can search only prefixes while ignoring the diacritics.

So the 5.0 solution would be to disable the '[x] Search whole words only' checkbox whenever the "Respect diacritics / Match within words" is selected
And moving the '[ ] Search whole words only' checkbox below the 'Search mode' dropdown -- so that's clear it is sub-option

Ludek

2021-01-13 19:12

developer   ~0061315

Last edited: 2021-01-13 21:39

View 2 revisions

As for the current UI confusion, another solution could be that once the '[x] Search whole words only' checkbox is checked then the dropdown text would change from
'Ignore diacritics / match beginning of words'
to just
'Ignore diacritics'

Ludek

2021-01-13 21:37

developer   ~0061319

Last edited: 2021-01-13 21:38

View 2 revisions

Fixed in 2294 by moving the checkbox below the dropdown and make it enabled just when the first choice is seleted.

Search mode: ['Ignore diacritics / match beginning of words (faster)'^]
-- '[ ] Search whole words only'

lowlander

2021-01-14 20:33

developer   ~0061331

Verified on 2294, documentation updated.

Ludek

2021-01-18 15:32

developer   ~0061415

FYI: Whole words searching in 'Respect diacritics' mode was added in 2296 (in course of 0017395), so the '[ ] Search whole words only' is no longer disabled in that mode

Ludek

2021-10-14 15:46

developer   ~0065205

Last edited: 2021-10-14 15:46

View 2 revisions

Re-opened to implement what I have originaly suggested in my note 0017276:0061315 to prevent from confusion


i.e. once the '[x] Search whole words only' checkbox is checked then the dropdown text would change from
'Ignore diacritics / match beginning of words'
to just
'Ignore diacritics'

rusty

2021-10-14 15:57

administrator   ~0065207

Last edited: 2021-10-14 15:58

View 2 revisions

Per discussion, the following approach would make most sense--a single combo-box with:
1) Ignore diacritics / Match beginning of words (faster)
2) Ignore diacritics / Search whole words only (faster)
3) Respect diacritics / Match within words
4) Respect diacritics / Search whole words only

Ludek

2021-10-14 19:57

developer   ~0065211

Last edited: 2021-10-14 20:08

View 2 revisions

Note that we sould also move this combo box at the top as it applies for both contextual and global search types. Just searching track entities fails to "match within words" (while it works fine for others entities like album/artist/genre/etc.)
i.e. "match within words" needs to be implmeneted also for tracklist contextual search

EDIT: This was entered by Rusty as 0018425

Ludek

2021-10-17 19:15

developer   ~0065274

Fixed in 2511

lowlander

2021-10-22 18:15

developer   ~0065450

Verified changes in Options on 2511.