View Issue Details

IDProjectCategoryView StatusLast Update
0017261MediaMonkey 5UPnP / DLNApublic2022-05-19 17:28
ReporterLudek Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0017261: MediaMonkey service failure (regression)
Description1) Install regular build 2288 (not portable)
2) Go to Options > Media Sharing and click [Install as service...]
3) Accept the UAC prompt and enter your account credentials
=> error: [SC] StartService: Open service failed: 1060:
Specified service does not exist as an installed service

Reported at:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97938
TagsNo tags attached.
Fixed in build2625

Relationships

related to 0017211 closedLudek Start Media Server only after Setup Wizard is closed 
related to 0018947 closedpetr DBNAME and /INI File directive on startup is not being respected 
related to 0017270 closedpetr UAC dialog is hidden (until user clicks shield icon on taskbar) 

Activities

Ludek

2020-12-20 21:03

developer   ~0060964

Last edited: 2020-12-21 13:29

View 4 revisions

Sometimes the service was installed correctly, but then it failed to start anyway (regression introduced while fixing 0017211 )

=> Fixed in 2289

The only that I have not resolved so far is that the UAC prompt dialog is hidden (until user clicks it on taskbar).
So it may be easily overlooked by users and thus the service installation is never completed (until user accepts the UAC prompt).
This isn't regression in MM5, but is regression against MM4 (where UAC prompt pop-ups in foreground in the dimmed window) and would be good to fix for 5.0.
EDIT: Tracked as 0017270

peke

2020-12-22 02:04

developer   ~0061015

Verified 2289

Unable to replicate anymore.

Ludek

2022-05-12 10:45

developer   ~0068111

Re-opened:

Testing 5.0.2.2532 and 5.0.3.2623 and in both cases I am unable to install the service with following error:
image.png (18,069 bytes)   
image.png (18,069 bytes)   

Ludek

2022-05-12 10:45

developer   ~0068112

UAC dialog isn't shown at all for some reason.

Plus user claims that MM5 service does not work in 5.0.3 , see: https://www.mediamonkey.com/forum/viewtopic.php?t=101916

Ludek

2022-05-12 14:45

developer   ~0068116

Last edited: 2022-05-12 14:55

View 3 revisions

Re-the problem with UAC not showing + subsequent failure to install service, I've spent several hours on inspecting this problem, but the problem is self-resolved by Windows 10 update to 21H2 edition.

Re the problem of service malfunctioning (originally reported as last working in 2611), I can confirm this issue.
It is regression introduced to build 2612 (caused by fix of 0018947 )

=> Fixed in 5.0.3.2625

peke

2022-05-13 20:33

developer   ~0068138

Verified 2625

Service installs normally and UAC prompt shows correctly. Also tested manual change service permissions

peke

2022-05-19 17:28

developer   ~0068166

User confirmed that service is working normally past 3 days.