View Issue Details

IDProjectCategoryView StatusLast Update
0017235MediaMonkey 5Casting (Google Cast / UPnP)public2022-12-15 13:26
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.1Fixed in Version5.1 
Summary0017235: Fallback to internal player (when configured player is inaccessible) may be undesired
DescriptionIn cource of solving issues 0016671 and 0016611 we added fallback to Internal player when the configured remote player is inaccessible.

But currently the fallback happens even immediatelly after MM start which may be unexpected:
1) Start MM5, start PlayerXXX and cast some songs to it
2) Close MM5
3) Turn off PlayerXXX
4) Start MM5
=> error message is shown "The PlayerXXX player is turned off or inaccessible."
5) click [OK]
=> MM auto-switched to the "Internal Player"
6) Turn on PlayerXXX
7) Play a track in MM5
=> MM plays to internal player and user needs to manually switch to PlayerXXX



Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=475694#p475694
TagsNo tags attached.
Fixed in build2800

Relationships

related to 0016671 closedLudek Chromecast: improved usability in case of unavailable chromecast 
related to 0018691 closedLudek Change "'The %s player is turned off or inaccessible.'" from message dialog to toast message 

Activities

Ludek

2022-09-14 16:17

developer   ~0069269

Because the message is a toast message now (see 0018691) it would make sense to revert 0016671 , i.e. doesn't fallback to Internal Player, but rather keep showing the toast message until user switches to another player manually.

Ludek

2022-12-15 13:25

developer   ~0070579

Last edited: 2022-12-15 13:26

Fallback deactivated in 5.1.0.2800