View Issue Details

IDProjectCategoryView StatusLast Update
0017232MediaMonkey 5Help / Docs / Localizationpublic2021-01-25 18:55
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017232: Add KB article for casting issues
DescriptionThis issue should be documented (or add a KB article): https://www.mediamonkey.com/forum/viewtopic.php?p=475690#p475690

By default MM utilizes its own media server to share the local files with other players on network, it is in Options > Media Sharing.
If you disable the default media server then it is creating temporal invisible media server with the random port (to be able to serve the local files to the remote player).
With firewall like MCAffee the MM server port is not allowed by default and it is also even hard to understand for users why the MM port is needed when casting local files to the home players (be it Google cast or DLNA player)

It can then refers to the point 2. (firewall configuration) in this
https://www.mediamonkey.com/support/knowledge-base/mediamonkey-upnp-dlna/mediamonkey-upnp-server-inaccessible/
(already existing article for MM server not accessible)
TagsNo tags attached.
Fixed in build

Relationships

related to 0016349 closedLudek Wording changes re media sharing (because of Google Cast support) 
related to 0017234 newrusty Improve error messaging re failed casting 

Activities

lowlander

2020-12-16 17:33

developer   ~0060808

1) Why not use the same port as set in for the Media Server (which is disabled), so if a user had that enabled in the firewall this problem is prevented in the first place?

2) Why does this not trigger a firewall prompt like it does when enabling the Media Server?

lowlander

2020-12-16 18:04

developer   ~0060812

https://www.mediamonkey.com/support/knowledge-base/mediamonkey-upnp-dlna/mediamonkey-upnp-server-inaccessible/
and
https://www.mediamonkey.com/wiki/WebHelp:Setting_UPnP_DLNA_Media_Servers/5.0

updated to reflect that casting will also need Firewall permissions

Ludek

2020-12-16 19:09

developer   ~0060825

1) might be, but if would user enable the default server while the temporal would be running for the casting then these two servers would be in conflict
But note that MM always uses the default configured MM server when available (i.e. in the default install)

2) it does trigger, but e.g. Barry is using McAfee firewall, MM can't auto-configure third party firewalls

rusty

2020-12-19 23:07

administrator   ~0060956

This was previously fixed. Note: I've revised the wording in the wiki slightly.

Ludek

2020-12-20 19:24

developer   ~0060963

Last edited: 2020-12-20 19:24

View 2 revisions

BTW: Here https://www.mediamonkey.com/forum/viewtopic.php?p=475865#p475865 user found that BubbleUPnP on his PC brokes casting from MM5 to Chromecast.
I haven't tested BubbleUPnP on my PC yet, but from what I see here: https://bubblesoftapps.com/bubbleupnpserver2/
It creates proxies for the available media servers -- so I yes, it interferes with the other media servers.

I guess we sould add this to the KB article.

lowlander

2020-12-21 19:20

developer   ~0061003

Covered in item 3: https://www.mediamonkey.com/support/knowledge-base/mediamonkey-upnp-dlna/mediamonkey-upnp-server-inaccessible/

rusty

2020-12-25 02:50

administrator   ~0061073

Martin, I'd suggest splitting out Casting into a separate article as it seems that the issues are different and in most cases much simpler.

lowlander

2021-01-15 19:44

developer   ~0061382

Casting (the DLNA part) uses settings from the Media Server, so I prefer to keep it together. It's all using the same technologies, so I prefer to have it in 1 place so it's easier to locate.

When referring to casting it is linked directly to the appropriate section within the page.