View Issue Details

IDProjectCategoryView StatusLast Update
0017131MediaMonkey 5Install/Configpublic2021-05-27 09:10
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0 
Summary0017131: Move sample extensions from MM installer and into the Wiki/Addons site
DescriptionThis bug covers a couple of tasks related to the fact that the SampleScripts directory currently appears to include a combination of various scripts that should be categorized and placed in there correct locations:
1) Core scripts: scripts that are part of MM5 core functionality should be in a different directory.
2) Ready-to-use addons: addons that were written for teaching purposes, but that are useful to end users should be added to the addon repository.
3) Sample Addons: unpolished scripts that aren't useful to end users because they've been created solely for teaching purposes should be removed from the installer and placed in a directory online that will be linked to from the MM5 Developer documentation that Drakinite will work on. OR if we prefer, they could be kept in the SampleScripts directory and the Developer Docs will refer to them there.
Note: all 3 categories of scripts will be referenced by MM5 Developer docs, but they still should be categorized properly so that it's clear what they are and so that end-users can easily access useful addons from the Addons directory.

First steps should probably be to:
- move core addons
- of the remaining addons, identify which are intended to be used by end users in the addons site

Then Drakinite, who's updating the MM5 dev docs and extensions site, can proceed with the rest.
TagsNo tags attached.
Fixed in build

Relationships

related to 0017860 feedbackrusty When installed Sample scripts are distributed extracted instead of in MMIP 
related to 0017926 closedLudek Sample scripts: Sample scripts should be updated along with New MM version update 

Activities

Ludek

2020-11-26 16:23

developer   ~0060382

Last edited: 2020-11-26 16:32

View 5 revisions

1) Core scripts are already in the /Scripts/ directory (as pre-installed scripts).

2) I removed 'googleMusicUploader' from SampleScripts, because Google Play Music service is already down -- so it is no longer working.

3) I guess that most of the current addons from sampleScripts belongs to this category with exception to: showLinks, HighlightBitrate, pulsingPause?, randomAlbumPlay, tabCloseButtonsVisible
We can just leave this teaching scripts in the SampleScripts folder bundled with the installer.

So for now we could just move showLinks, HighlightBitrate, pulsingPause?, randomAlbumPlay, tabCloseButtonsVisible to the addons site.

jiri

2020-11-27 10:05

administrator   ~0060392

Last edited: 2020-11-27 10:05

View 2 revisions

1) All core scripts are already distributed with MM5, no more from Sample Scripts are needed. However, currently these scripts are both in Scripts and SampleScripts folder. They should be removed from SampleScripts to make things cleaner. (Petr?)

2) HighlightBitrate, pulsingPause, randomAlbumPlay, showLinks, sqleditor, tabCloseButtonsVisible and possibly refreshSkinButton all seem to be useful enough to be published in the Addon Repository (possibly with some tweaks). (Jordan)

3) Per discussion with the devs, we'll rather continue to distribute the rest of scripts in the SampleScripts folder, which makes it easier to keep them updated and Jordan can refer to them from Wiki anyway. We can decide to change this policy sometimes in the future (5.1 release?), when the set of scripts stabilizes and doesn't need frequent updates. We should change their distribution from MMIP to unpacked folders though, so that they are easily accessible for anyone interested. (Petr?)

drakinite

2020-12-08 04:44

developer   ~0060618

Last edited: 2020-12-08 04:44

View 2 revisions

RefreshSkinButton is pretty close to my ReloadShortcut addon, since they do exactly the same thing but go about it in two different ways. I think it'd be better to have only one of the two on the addons list.

I could port the hotkey functionality from ReloadShortcut to RefreshSkinButton, add a checkbox option to enable/disable the button itself, and then remove ReloadShortcut from the addons listing. Does that sound like a good idea?

jiri

2020-12-08 07:40

administrator   ~0060619

Sounds good to me.

drakinite

2020-12-08 21:48

developer   ~0060632

As discussed, tabCloseButtonsVisible is now redundant because the close buttons were switched to always visible by default, likely as per user feedback. Renamed the extension to tabCloseButtonsHover, and it now does the opposite (enabling closeBtnOnHover instead of disabling it).

drakinite

2020-12-08 23:43

developer   ~0060634

Last edited: 2020-12-08 23:52

View 2 revisions

highlightBitrate, randomAlbumPlay, showLinks, sqleditor, tabCloseButtonsHover, and refreshSkinButton are all up on the addons repo. HighlightBitrate doesn't have a very attractive icon, so I left it out for now. For some reason, pulsingPause doesn't work on the latest build. I'll take a look and try to fix it soon.

They're all in the ~ MediaMonkey 5 (beta) category, but I'll move them once the new categories are set up.

drakinite

2020-12-13 06:57

developer   ~0060754

SampleScripts are now in subcategories in the addon site.
- Show Links, Pulsing Pause, and tabCloseButtonsHover are now in appearance
- Highlight Bitrates and Random Album Play are now in Management
- SQL Editor and Refresh Skin Button are now in Developer Tools

I set Show Links is set to display on top in the Appearance category, because it essentially re-enables a MM4 feature.