View Issue Details

IDProjectCategoryView StatusLast Update
0017117MediaMonkey 5Generalpublic2020-11-28 12:08
Reporterdrakinite Assigned To 
PriorityurgentSeveritytrivialReproducibilitysometimes
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0017117: MMIPs have no icons when registered to MM5
DescriptionI fully uninstalled & reinstalled MM5 to check, and it appears that MMIPs don't get an icon when registered with a non-portable version of MM5. Might be a regression? Not a huge priority, but still something that's broken.

Re: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97694
TagsNo tags attached.
Fixed in build2276

Activities

Ludek

2020-11-20 17:21

developer   ~0060299

I can replicate with 2274, but cannot replicate with current sources and/or earier builds.
Couldn't this be a regression caused by changing the tray icon to white/dark style?

drakinite

2020-11-20 17:52

developer   ~0060302

I don't really know, but MMIPs never had an icon for me when set to open with MM5, and I've been using it since build 2258. Is there a way for me to test if it's some sort of strange fluke? I'm experiencing it on two computers, but I did initially install MM5 around the same time on both computers.

petr

2020-11-27 15:18

developer   ~0060400

Last edited: 2020-11-27 15:53

View 2 revisions

black/white icon is used just for taskbar icon ... original icon is still present in exe resources and still have same index/name.

EDIT: problem is we're not including association icons at all ... probably you have them registered still to exe from MM4

drakinite

2020-11-27 19:46

developer   ~0060405

Ludek seems to have MMIPs with the new MM5 logo, but I'm not sure how he has it working that way. (see https://www.mediamonkey.com/forum/viewtopic.php?p=474529#p474529)

If you'd like to add the one I suggested, though, there's an ico and png version in the OneDrive link at the top of the post. I can make changes if you'd like, too.

petr

2020-11-28 11:01

developer   ~0060411

Fixed

peke

2020-11-28 12:08

developer   ~0060430

Verified 2276

All icons are present.