View Issue Details

IDProjectCategoryView StatusLast Update
0017116MediaMonkey 5Install/Configpublic2020-12-06 18:07
Reporterrusty Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017116: Installation / Config localization requirements
Description1) Currently MM5 appears to include strings for all languages in the installer. It would be preferable that we follow the same conventions as in MM4. i.e. only include English and German.
a) all other languages should be listed based on the status. e.g. English; German; French (download);
b) do we also use 'beta' to indicate an incomplete language? e.g. Hungarian (download-beta). If so, is this dynamic?
c) the downloadable path will have to be different. e.g \sw\mmw\5\lang\<language>

2) Currently the installer appears to only run in English. It should be possible to choose other languages (or for it to automatically use the same language as the system it's running on, thereby obviating the need for a language chooser).

3) The installer (or the startup wizard) should give the user the choice of language that MM will run in.
TagsNo tags attached.
Fixed in build2280

Relationships

related to 0007438 closedpeke MediaMonkey (current) Automated download of localization files 
related to 0017144 closedpetr MediaMonkey 5 Language installation usability 
related to 0017177 newpetr MediaMonkey 5 Options: languages not listed in alphabetic order 

Activities

petr

2020-11-23 20:51

developer   ~0060361

Fixed

rusty

2020-11-28 23:36

administrator   ~0060439

Last edited: 2020-11-29 17:39

View 4 revisions

Tested 1) with https://www.mediamonkey.com/sw/mmw/5/lang/fr.mmip and it doesn't seem to work in 2276.

Update: I also tested with https://www.mediamonkey.com/sw/mmw/5/lang/fr/fr.mmip and that doesn't work either :-( [EDITED]

1b) beta builds of MMW5 included numerous MMIP files that in many cases are out-of-date. Is there a way to ensure that MM always installs the most up-to-date translation file when the user switches languages (instead of downloading an outdated file that was previously included with a beta build)?

petr

2020-11-29 09:44

developer   ~0060443

Last edited: 2020-11-29 13:23

View 3 revisions

DL path was 'https://www.mediamonkey.com/sw/mmw/5/lang/fr', but based on our offline communication i've change to https://www.mediamonkey.com/sw/mmw/5/lang/fr.mmip for a next build.
1b) we can force language download when there's no info.json file in language folder (in info.json we already have versioning so it will be used once updating mechanism is done)

EDIT: i'm getting 403 error when trying https://www.mediamonkey.com/sw/mmw/5/lang/fr

rusty

2020-11-29 17:38

administrator   ~0060447

Yes it's at https://www.mediamonkey.com/sw/mmw/5/lang/fr/fr.mmip :-(

rusty

2020-11-29 17:43

administrator   ~0060448

Last edited: 2020-11-29 19:20

View 2 revisions

Based on Petr's last comment, this will be fixed in 2277. Resolving.

Note that the way this will work is:
i) switching languages will always download the latest language mmip file
ii) manually copying the .mo file to MediaMonkey directory \Locale\<LanguageCode>\LC_Messages\Default.mo
will overwrite the existing .mo file so that translators can test their string updates as before.

rusty

2020-11-30 02:23

administrator   ~0060453

2) Verified that running the installer in french works. However, at the end of the install process a failed download error results. This needs to be retested since the along with the failed download, if the user subsequently changes the language settings via the Options dialog, the following strings fail to translate:
a) Tree Node “Playlists” (sometimes--this is inconsistent probably due to test variation), along with sub-nodes "Accessible Tracks"; “Most played (50)”; “Top rated (6 hrs)”; ”Recently added”; “Unrated (1 GB)”
b) Several root nodes: Music, Classical Music, Podcasts, Audiobooks, Video, TV

c) The error associated with a failed download indicates in brackets 'Parameter analysis error' (that's a rough translation). That error doesn't seem to make sense since the error is that the translation file is unavailable.
installer_language-error.jpg (15,023 bytes)   
installer_language-error.jpg (15,023 bytes)   

petr

2020-11-30 08:55

developer   ~0060456

Last edited: 2020-11-30 14:20

View 2 revisions

re 2a, 2b) playlist names and collections are translated when they're created (on first run) and then stored to the DB ... they're not 'retranslated' when language is changed (it is same behavior as in MM4)
re 2c) fixed

rusty

2020-12-01 02:26

administrator   ~0060474

Tested 2277 partially:

2)d) Selecting a language in the installer (e.g. French) causes the installation to proceed in French, but then MediaMonkey runs in English (resulting in a non-localized DB)!

petr

2020-12-01 10:21

developer   ~0060481

Fixed

rusty

2020-12-01 17:28

administrator   ~0060488

Re. opening in relation to 1b) since in 2277 neither the installer, nor the Options dialog communicate to the user whether a language is a 'beta'. This is important because otherwise users will think that all translations are final and will get a very poor initial impression of the product if they're using a non-final translation.

It should appear along the following lines:
English
Deutsch - beta
Espanol - beta (download)
Francais (download)

petr

2020-12-03 14:19

developer   ~0060529

Fixed

rusty

2020-12-03 22:05

administrator   ~0060541

Last edited: 2020-12-03 22:42

View 3 revisions

Tested 2278. There seem to be regressions:
1b) The installer still doesn't indicate whether a language is a beta or not
2d) Choosing a language in the installer causes the installer to run in french, but when MMW is launched, it still runs in English!
3) Tools > Options > Language chooser doesn't work at all (it doesn't give a choice of any language other than English)
4) The installer doesn't have ES-CH
5) Just prior to the last step of the installer, the install wizard flashes (something briefly appears and then disappears)

rusty

2020-12-03 23:21

administrator   ~0060544

As pointed out by Petr, 2d) & 3) are actually working, but not for portable mode. They both seem to be working correctly in a regular install.

rusty

2020-12-04 05:46

administrator   ~0060548

Tested 2279 and 2d/3/4/5 are fixed but the following issues remain:
1b) The installer still doesn't indicate whether a language is a beta or not

6) Several languages fail to install with the following error: "Invalid Addon! Cannot open file "". The filename, directory name, or volume label syntax is incorrect."
es-AR
es-CH
pt-BR
note: I didn't test all languages only focused on those that have been completed to-date.

7) The following aren't labelled as beta even though they are beta:
Norway
Swedish
Hans
Hant

8) In the installer, languages are listed alphabetically. But in Tools > Options > Languages they're not fully in alphabetic order. They should be.

petr

2020-12-04 07:50

developer   ~0060549

Last edited: 2020-12-04 16:58

View 2 revisions

Items 1, 6, 7 are fixed

rusty

2020-12-06 03:02

administrator   ~0060564

Last edited: 2020-12-06 03:51

View 3 revisions

Tested 2280:
1b) Verified. Installer now shows beta status

2) Regression: portable installs work correctly, but now, installing a regular install (clean) and choosing French --> MMW5 runs in English!

6) Verified (languages install correctly from the Options dialog)

7) Labels re. beta status are incorrect in the installer (this is strange, since beta status displays correctly in the Options menu!
Serbian, German are both missing beta tags
Korean is tagged as beta even though it's complete

8) Open

rusty

2020-12-06 03:53

administrator   ~0060567

petr

2020-12-06 13:16

developer   ~0060571

Item 2, 7 fixed

rusty

2020-12-06 18:05

administrator   ~0060587

Verified 2, 7 in 2280. Opening a lower priority issue to track item 8).