View Issue Details

IDProjectCategoryView StatusLast Update
0017071MediaMonkey 5Extensionspublic2020-12-19 18:07
ReporterLudek Assigned To 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017071: Double-clicking a file when MM5 is closed fails to open
Description1) Use MM5 compatible MMIP (tested with FPSConter.mmip from https://www.mediamonkey.com/forum/viewtopic.php?f=27&t=97677 )
2) Associate MM5 with the *.mmip extension
3) Close MM5
4) Double-click the MMIP in the windows explorer

=> MM5 starts, but nearly after showing the splash screen it crashes !
=> new folders 'GPUCache' and 'chromium' are create inside the folder where the MMIP resides !

Workaround: Keep MM5 opened while double-clicking the associated files

EDIT: The same issue happens for any file type (including MP3 associated with MM5)
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97694
TagsNo tags attached.
Fixed in build2284

Activities

petr

2020-11-13 13:28

developer   ~0060175

Fixed

peke

2020-11-14 13:51

developer   ~0060202

Verified 2274

if MM5 is associated with files it correctly opens on double click.

Folders are not created.

drakinite

2020-11-22 21:11

developer   ~0060342

Reopened; It looks like when "Allow only one instance of MediaMonkey" is disabled, opening an MMIP causes a new instance of MM to open. I don't believe that is intended behavior.

petr

2020-11-22 21:57

developer   ~0060343

Tried how MM4 works and you're right ... running instance is used.

petr

2020-11-23 20:13

developer   ~0060358

Fixed

peke

2020-11-28 11:50

developer   ~0060419

Verified 2276

Running instance is used.

drakinite

2020-12-01 17:35

developer   ~0060489

New bug, unfortunately:
If you double-click mmip while closed, then close the installation prompt, you will get a new installation prompt with every subsequent reload.

1) Open MMIP when MM5 is closed
2) click X
3) Reload window
4) A buggy-looking installation prompt will appear

The only way to stop the installation prompts is to fully close and reopen MM.

drakinite

2020-12-01 17:35

developer   ~0060490

image.png (53,468 bytes)   
image.png (53,468 bytes)   

petr

2020-12-02 08:45

developer   ~0060498

Fixed

peke

2020-12-06 18:32

developer   ~0060589

Verified 2281

Unable to replicate in 2281.

drakinite

2020-12-12 22:07

developer   ~0060745

Regression - Opening MMIP when MM5 is open, when "Allow only one instance of MediaMonkey" is enabled, once again opens a new instance of MM5. 0017071:0060342

petr

2020-12-14 18:07

developer   ~0060766

Unable to reproduce in current build (2284)

peke

2020-12-14 19:46

developer   ~0060769

Verified 2284

I am also unable to replicate in 2284

peke

2020-12-19 18:07

developer   ~0060949

Re verified 2288

Still unable to replicate.