View Issue Details

IDProjectCategoryView StatusLast Update
0016888MediaMonkey 5Install/Configpublic2020-08-28 11:38
Reporterlowlander Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016888: Settings are lost on MediaMonkey restart
DescriptionVarious users are reporting that 2262 can loose settings on MediaMonkey restart. It looks like persistent.json may fail to save for some users when MediaMonkey is killed by system. Although IYF-952-64645 reports manually exiting MediaMonkey.
Additional InformationIYF-952-64645
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97113
TagsNo tags attached.
Fixed in build2265

Relationships

related to 0016234 closedpetr Exception on windows restart/shotdown 
related to 0016892 closedLudek Folder Monitoring settings lost on restart -- regression 2264 

Activities

Ludek

2020-08-13 13:26

developer   ~0059383

Last edited: 2020-08-13 13:53

View 7 revisions

Fixed in 2264:
- MediaMonkey.ini is saved after every change in Options dialog and also regularly 5 seconds after a view change
- persistent.json is saved also regularly (5 seconds after a view change) and also on app close, but to the temporary persistent.json.tmp file at first -- and only after verification that the file was written correctly then the original persistent.json file is safely replaced by the tmp file

This meets MS recommendation here: https://docs.microsoft.com/en-us/windows/win32/shutdown/wm-endsession
Namely Remarks:
Applications that have unsaved data could save the data to a temporary location and restore it the next time the application starts. It is recommended that applications save their data and state frequently; for example, automatically save data between save operations initiated by the user to reduce the amount of data to be saved at shutdown.

peke

2020-08-14 22:49

developer   ~0059410

Verified 2264

Unable to replicate.

TEST Note:
MediaMonkey.ini: Open MM5 Options any change option that is not enable/disabled in previous MM5 run and Keep Options Open -> Restart Windows -> Use Force restart when MM is listed as obscuring restart app -> Start MM5 all settings are there
Persistent.json: Same steps as above ith exception just change skin in MM5 and Initiate Windows Restart.
HINT: It is important to click Force restart if shown so that all opened apps are killed abnormally.

lowlander

2020-08-16 17:25

developer   ~0059424

Forum reports this isn't fixed in 2264: https://www.mediamonkey.com/forum/viewtopic.php?p=471575#p471575

Ludek

2020-08-24 13:48

developer   ~0059463

Last edited: 2020-08-24 13:49

View 3 revisions

I am still not quite sure what the issue is, based on the forum posts it seems that kind of disc cleaning utility might be deleting our persistent.json file (at least based on the post from user CraigG )

CraigG:
its happened again twice since posting this. I have had Windows updates and I ran Disk Clean. Do you think either or both of these did it?
Odly, this only happens the first time I open MM in the morning. I can open and close it all day and night with no issue. It is the next day when it happens.


I resolved it by saving also copy of persistent.json (as persistent.json.bck) and checking the file on MM5 start.
persistent.json.bck is used whenever persistent.json does not exists or has different file size.

Fixed in 2265

Ludek

2020-08-24 14:33

developer   ~0059464

Finally I most probably found a glitch in MM5 code that was causing the issue.

Fixed in 2265.

peke

2020-08-28 11:38

developer   ~0059511

Verified 2265

Settings are preserved. Tested in normal close and abnormal close/terminate