View Issue Details

IDProjectCategoryView StatusLast Update
0016859MediaMonkey 5Main Panelpublic2020-10-25 13:31
Reporterlowlander Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016859: AV when inline tagging
DescriptionThis may have to do with the Album node being expanded (log seems to show a flurry of node deletions), but twice while inline tagging Original Date MediaMonkey threw an AV. Note that contextual search interferes in process as inline edit isn't always engaged when starting to type.
TagsNo tags attached.
Fixed in build2265

Activities

Ludek

2020-08-11 22:10

developer   ~0059336

Last edited: 2020-08-11 22:59

View 4 revisions

log IDs submitted: A65A698D, 8DAE698D -- these are freeze logs and based on the logs really seems to be related to expanded Albums node with thousands of children (39239 children) and subsequent mass deletion of the node children (-- after inline edit ??) reducing to 22845 albums for some reason. Still studing the logs/code to find the exact reason...

Ludek

2020-08-12 11:50

developer   ~0059350

Last edited: 2020-08-12 11:50

View 2 revisions

I finally found the steps how to consistently simulate the issue on LowLander's database with Albums node expanded in Media Tree

Fixed in 2263.

peke

2020-08-13 01:32

developer   ~0059362

Verified 2263

No regressions on my library with 15303 Albums
bug16859.jpg (201,593 bytes)   
bug16859.jpg (201,593 bytes)   

Ludek

2020-08-25 08:24

developer   ~0059467

Last edited: 2020-08-25 10:12

View 3 revisions

Re-opened: LowLander is still experiancing this issue (crashes 2A619EEA, FC059EEA ), debug logs sent via IM.
The issue happens after inline edit when Entire Library > Albums node is expanded with more than 30K children.

Fixded in 2265

peke

2020-08-28 11:46

developer   ~0059513

Reminder sent to: lowlander

Verified 2265

Unable to replicate, @Lowlander please confirm that there was no crashes in this version.

peke

2020-10-25 13:31

developer   ~0059982

Re verified 2271

Unable to replicate.