View Issue Details

IDProjectCategoryView StatusLast Update
0016768MediaMonkey 5Generalpublic2020-07-24 18:30
Reporterzvezdan 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016768: Black window on start and high CPU
DescriptionI cannot run any portable version of program since 5.0.0.2230. I tried several following versions including the latest one (5.0.0.2258) and all have the same problem, the black window appear on the start, the program consumes high CPU, and nothing is happening until I kill it. 5.0.0.2229 and previous work fine. Tested only on one Win7 machine. If you made program Vista and/or XP compatible, I would be able to test it even more.
Additional InformationSome info about this issue
https://monorail-prod.appspot.com/p/chromium/issues/detail?id=1002559
https://monorail-prod.appspot.com/p/chromium/issues/detail?id=920704
TagsNo tags attached.
Fixed in build2262

Activities

zvezdan

2020-07-01 14:24

updater  

Zvezdan-MM5 black window, high CPU.zip (34,952 bytes)

petr

2020-07-16 12:26

developer   ~0058986

Last edited: 2020-07-16 12:27

View 3 revisions

It's not possible to make it Vista/XP compatible as it's no longer supported by chromium (since 2016) and cannot be run in Vista/XP since 2018.

petr

2020-07-16 18:33

developer   ~0058988

Last edited: 2020-07-16 21:08

View 2 revisions

About the problem itself ... i've tried on virtual machine with Win7 running and work fine, but some chromium users mentioned something similar. Can you try to run with -disable-gpu parameter (this will disable hardware acceleration) ?

zvezdan

2020-07-16 19:47

updater   ~0058989

It works ok with the mentioned parameter.

petr

2020-07-17 08:25

developer   ~0058994

For build 2262 i've added new ini entry
[System]
disableGPU=1
so you do not need to use -disable-gpu parameter every run and will be used automatically.

zvezdan

2020-07-17 18:54

updater   ~0058999

That is not proper solution, unless you make that ini entry default. I suppose there would be other users trying your program for the first time and having the same issue they will give up and go looking for another program. The users don't like to search in forums and such places as Mantis to find solution for the problem.

You should look what you changed between b2229 and b2230 that caused this problem and try to resolve it properly without need for users to change anything in Ini files or anywhere else.

petr

2020-07-18 11:01

developer   ~0059018

Last edited: 2020-07-18 12:02

View 6 revisions

Between 2229 and 2230 we've moved to latest chromium version 79 and as i wrote before, it's a chromium bug. We can make this parameter as default for windows 7 or update to latest chromium (currently it's 83 i think ?), but we do not know if this issue is fixed and new version can bring another issue(s) ?

EDIT: as i do not see any easy way how to fix it (as it's not a bug in our code) i've enabled disable-gpu parameter by default when running on windows 7

zvezdan

2020-07-18 19:53

updater   ~0059019

I think it is wrong that you assume that this bug is manifesting only on Win7. I believe it is most probably related to the integrated graphics (Intel's built in CPU in my case) regardless of OS.

petr

2020-07-18 20:50

developer   ~0059020

Let's make a test ... based on some info "The crashes on Windows 7 with the 10.0.18362.1 version of d3dcompiler_47.dll are well known." and it's the version we're using ... can you test out with older dll (uploaded it here https://1drv.ms/u/s!AnuLNbx2rOzekvxIwe0hZqY5shVrSw?e=PxvqdK) ? Just replace this file in MM install folder and run without -disable-gpu parameter.

zvezdan

2020-07-18 21:40

updater   ~0059021

It works ok with the uploaded dll, as well as with the dll from b2229.

petr

2020-07-18 21:49

developer   ~0059022

ok ... question is whether it's better to disable HW acceleration (for Win7 users) and use newer library or use old library. I prefer to disable HW acceleration.

zvezdan

2020-07-18 22:59

updater   ~0059023

I am wondering how Opera resolved the same problem:
https://forums.opera.com/topic/32337/solved-black-screen-instead-of-browser-after-update

zvezdan

2020-07-18 23:10

updater   ~0059024

I just installed the latest portable version of Opera. It uses the old dll (10.0.17134.12).

rusty

2020-07-19 01:58

administrator   ~0059025

Another possibility: use the old version on Win 7, and the new one on Win 10 (my laptop runs win10 and uses intel graphics without issues) ? Seems like a pita, but if the issue isn't being fixed by intel/ms...

petr

2020-07-19 06:04

developer   ~0059026

Last edited: 2020-07-19 06:05

View 2 revisions

It's actually nothing to fix by MS ... based on information i have it is caused by Universal CRT integration since 10.0.18362.1 and some Windows 7 installations haven't all required libraries installed which cause crash (and chromium keeps opening GPU process again and again and ...).

zvezdan

2020-07-19 19:05

updater   ~0059030

I just installed the latest Google Chrome and it has the same old dll file as Opera. Obviously, they all give up from the 10.0.18362.1, and I think you should do the same. Although, I like the idea to distribute both versions and use the old one with Win7 and the new one on Win10. You already have two d3dcompiler_47.dll files, one in the main folder and another in the chromium folder, so you should just replace one of them with the old version.

petr

2020-07-19 19:31

developer   ~0059031

OK ... you're right ... i looks chromium 79 works just fine with older d3dcompiler so i'll install older version in windows 7.

petr

2020-07-24 16:56

developer   ~0059104

Last edited: 2020-07-24 16:57

View 2 revisions

To be clear ... i've updated installer so old version of d3dcompiler is installed in windows 7 system.

zvezdan

2020-07-24 17:29

updater   ~0059105

Just to clarify, what do you mean by "installed"? What happens if I install the portable version of the program on Win10 on USB drive and latter I use the same drive on Win7?

petr

2020-07-24 18:05

developer   ~0059106

If you install on win 8+, new d3dcompiler will be installed (even with portable version).

zvezdan

2020-07-24 18:08

updater   ~0059107

I think it would be better if your program choose which dll will use on startup, not during installation.

petr

2020-07-24 18:18

developer   ~0059108

It can be complicated as it is used by chromium and must be in 'root' folder ... will try to search more info and experiences with usage of this older library even in win8+ systems so we do not need to use two versions.

zvezdan

2020-07-24 18:25

updater   ~0059109

Then why you have two d3dcompiler_47.dll files, one in the "root" folder and another in the chromium folder?

By the way, portable Google Chrome doesn't have that file in the "root" folder with the main exe file.

petr

2020-07-24 18:28

developer   ~0059110

Last edited: 2020-07-24 18:30

View 2 revisions

It's no longer in chromium folder. Anyhow i see even latest Chrome 84 uses old d3dcompiler (even in win8+ systems) so we will use it as well.