View Issue Details

IDProjectCategoryView StatusLast Update
0016766MediaMonkey 5Playlists (Auto) / Search / Filterspublic2020-11-16 18:40
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016766: Using Column Filter with Contextual Search yields incorrect search results
DescriptionIf the user initiates and then cancels a contextual search while the column filter is being used, the column filter starts behaving incorrectly and displays incorrect search results:

1 Go to Music > All tracks [List:Column filter]
2 Use the column filter to select Genre: Alternative and Rating: 3-5 stars
3 Type an artist name to generate contextual search results
--> Incorrect search results appear (it seems that somehow, MM selects other Genres (in the column filter) by itself, unexpectedly restricting search results)
4 Press 'x' or ESCAPE to close the contextual search
--> some of the column filter restrictions are eliminated, and others aren't, resulting in a second set of incorrect search results!

https://www.screencast.com/t/xFUmZyrvrw0
Additional InformationRaised (though described differently) at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95726#p464363
TagsNo tags attached.
Fixed in build2260

Relationships

related to 0016457 closedLudek Column Filter fails to update correctly when filters are enabled 
related to 0015734 closedLudek Contextual search does not work right when 'Column Browser' is opened after the search 
related to 0017104 closedLudek Possible crash when using search and switching from 'List' to 'Grid' 

Activities

Ludek

2020-07-01 17:42

developer   ~0058718

Last edited: 2020-07-01 17:47

View 3 revisions

The reason for the incorrect search results was a change in behaviour when fixing 0016457
where MM tries to restore Column Filter selection after using Contextual search, but as can be seen on the video (0:55) the selection generaly cannot be restored because simply some items are no longer in the given categories.
e.g. genre 'Alternative' does not iclude any track with 'costa' and thus is no longer as a row in the Genre column of the Column Filter.

Fixed in 2260 be reseting the 'Column Filter' selection after using contextual search -- so that all search results are visible (and no longer filtered by Column Browser).

i.e. filtering works in sequence [Funnel filter > Contextual search > Column Filter]
i.e. results of Funnel filtering are filtered by Contextual search and the search results are filtered by Column Filter

peke

2020-07-11 16:38

developer   ~0058894

Verified 2260

This no works for me.

peke

2020-11-15 22:45

developer   ~0060247

Re Verified 2274

No regressions found.