View Issue Details

IDProjectCategoryView StatusLast Update
0016670MediaMonkey 5Extensions frameworkpublic2021-11-08 15:41
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016670: Extension updates may result in settings loss / multiple MM windows
DescriptionIn the course of testing codec pack updates, I found that although extension updates generally work well, there are a couple of issues related to the update process:
1) Restart of MediaMonkey causes Window settings to be lost. This isn't a major issue, unless it can also cause other settings to be lost.
2) Restart of MediaMonkey can cause multiple MM5 windows to run, generating errors
I suspect that both of these are related to incorrect termination/restart of MM.

See (with process explorer showing running/closed MM instances):
https://www.screencast.com/t/AwlpkoTy
Steps To ReproduceTo replicate:

1 Make sure no codec pack is installed, and restart MM
2 Change the window size
3 Install codec pack 3.0.2
--> MM restarts but new window size isn't the last saved size!
4 Go to extensions and 'Find Updates'
5 Initiate the update to codec pack 3.0.3 trial
--> MM tries to restart, but fails to do so successfully!
--> error results due to multiple instances of MM running!
TagsNo tags attached.
Fixed in build2254

Relationships

related to 0016440 closedpetr Extension installation: 'Restart' doesn't restart MM 
related to 0016396 closedpetr Crash reporting: 'Restart' button never works 
related to 0016706 closedpetr Plugins: Restart do not work correctly in some cases 

Activities

rusty

2020-05-28 14:28

administrator  

update-log-2252.7z (141,454 bytes)

Ludek

2020-05-30 20:32

developer   ~0058380

Last edited: 2020-05-30 20:34

View 3 revisions

This seems a recent regression in app.restart(); introduced by Petr while fixing 0016396

i.e. MM5 is not properly closed, but is killed by the restart.bat instead

petr

2020-05-31 20:23

developer   ~0058387

Fixed

rusty

2020-06-02 02:44

administrator   ~0058402

Verified 2254. Closing.