View Issue Details

IDProjectCategoryView StatusLast Update
0016440MediaMonkey 5Extensions frameworkpublic2021-11-08 15:41
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016440: Extension installation: 'Restart' doesn't restart MM
DescriptionUpdating an extension per the process below causes the Restart button to fail:

1 Click Tools > Extensions > Add...
2 Choose MediaMonkey Codec Pack 3.0.2 from the local drive (3.0.1 is already installed)
--> The codec pack is installed and a notification appears instructing the user to restart the app
3 Click 'Restart'
--> Nothing happens!
4 Close MediaMonkey and then restart it manually
--> Codec pack was updated correctly (i.e. there wasn't a frozen process preventing the Restart)

Note: this was a portable installation
TagsNo tags attached.
Fixed in build2234

Relationships

related to 0016670 closedpetr Extension updates may result in settings loss / multiple MM windows 

Activities

peke

2020-03-20 05:20

developer   ~0057242

I am unable to replicate steps in 2230-2232, but was able costantly to replicate in 2233. Especially in clean install.

Steps:
1. Install 2233 Portable
2. Cancel inpmort MM4 and cancel First start wizard
3. tools -> Extensions -> Add -> Codec 3.0.2
4. Closed extensions dialog -> Restart -> Yes -> Nothing Happen
5. Closed MM5 (No restart log saved)
6. Started MM5
7. tools -> Extensions -> Add -> Codec 3.0.2
8. Closed extensions dialog -> Restart -> Yes -> Nothing Happen
9. Closed MM5 (No restart log 2 saved)
10. Compressed Portable folder with logs
11. Started 2230 existing installation
12. tools -> Extensions -> Add -> Codec 3.0.2
13. Closed extensions dialog -> Restart -> Yes
14. MM restarts normally -> Closed MM (compressed 2230 portable folder

Archives sent to Petr offline.

petr

2020-03-20 09:09

developer   ~0057243

Fixed

peke

2020-03-22 23:55

developer   ~0057281

Last edited: 2020-03-22 23:55

View 2 revisions

Verified 2234

Great work, looks like working for me.

peke

2020-03-27 01:40

developer   ~0057370

Retested 2235

All OK closing