View Issue Details

IDProjectCategoryView StatusLast Update
0016626MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-11-29 19:07
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0 
Summary0016626: Can't paste Artwork from browser [Regression]
DescriptionYou can no longer paste Artwork copied from a browser. The Context Menu in the Artwork tab of Properties fails to enable Paste. D&D from browser still works.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96592
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100481
TagsNo tags attached.
Fixed in build2271

Relationships

related to 0016612 closedpetr MM5 can crash during opening of Context menu can crash with specific clipboard content 
related to 0016526 closedpetr Can't D&D AVI and WEBM onto Player/NP 
has duplicate 0018180 resolvedpetr Dropping or pasting images to artworklist sometimes does not work 

Activities

Ludek

2020-05-20 13:24

developer   ~0058135

Last edited: 2020-05-20 13:33

View 2 revisions

This regression was caused by Petr's SVN revision 35604 (fix of 0016526) by changing line 533 in dndutils.js
from
var list = e.data || e.dataTransfer.items;
to
var list = this.getDroppedFiles();

petr

2020-05-20 19:12

developer   ~0058141

Fixed

peke

2020-05-22 22:27

developer   ~0058207

Verified 2251

No issues anymore. Also checked and no regressions in bug 0016526 fix.

petr

2020-07-29 16:58

developer   ~0059177

Added some debug messages in case this occurs again.

peke

2020-07-31 00:25

developer   ~0059183

Verified 2262

@Lowlander I am unable to replicate in concurrent 40+ paste

peke

2020-08-28 23:03

developer   ~0059528

Reminder sent to: lowlander

rusty

2020-09-24 15:56

administrator   ~0059678

Verified and closing. LL please re-open if this occurs again.

petr

2020-10-20 20:24

developer   ~0059910

Unfortunately logs didn't help to find an issue ... added some more debug messages.

peke

2020-10-23 11:46

developer   ~0059960

Verified 2271

Works with copy/paste and I also tested D&D for regression, no issues.

lowlander

2020-11-18 18:07

developer   ~0060278

Seen again on 2274 with Jay-Z - The Blueprint. Paste is not shown as part of the context menu. Note that this is hard to reproduce as it's a state MediaMonkey gets into at some point during long use. Paste is always available after starting MediaMonkey, but can at some point stop being shown. Log in same location as others.

petr

2021-06-07 14:38

developer   ~0063797

I cannot find the logs ... can you please upload on our FTP (into MM5/bugs folder) ?

lowlander

2021-06-08 23:57

developer   ~0063829

Still seen on 2413.

1) Right click on image in Firefox 89
2) Use WinKey+V to verify Artwork on Clipboard
3) Right click in Properties > Artwork
4) Paste is not enabled in Context Menu

Copy on a image file (gif and png tested) also doesn't enable Paste.

petr

2021-10-22 11:48

developer   ~0065417

It's hard to include as i do not know yet where the problem is. As Martin wrote "this is hard to reproduce as it's a state MediaMonkey gets into at some point during long use" and log didn't gave any clue why it stopped work. Martin, can we make a remote debug when this occur again ?

peke

2021-10-23 20:07

developer   ~0065470

Last edited: 2021-10-23 21:10

View 2 revisions

I am unable to reproduce 2511

Regarding browsers I tested Edge, Chrome, Firefox, WaterFox, Vivaldi, IE11 and tried both copy/paste image and Drag and drop, also on properties, Preview, Info. Then I tried HyperSnap, Paint, XNView, Irfan View.

Then also used few video players that can fetch Frame as image and copy to clipboard.

Note: MM5 as running more than 18h with few Sleeps, Hibernates and Hybrid Sleeps.

Only thing I can think about is that you add MSG with Dragged Object Type info in case dragged object can't be dragged on Preview or Properties -> Artwork. I gues ssame can be done when you check if content of Clipboard can be pasted into MM? But this is also wild guess and most likely too complicated to implement and with influence performance.

lowlander

2021-11-01 19:31

developer   ~0065623

I still was able to reproduce and capture screencast and log with 2513 which is available form the link above.

However it was only the one time. After the D&D of the Artwork it always shows Paste available, even after a MediaMonkey restart.

petr

2021-11-02 11:12

developer   ~0065636

Sent updated action.js with additional debug messages ... make a new log, please.

lowlander

2021-11-29 19:07

developer   ~0066158

Problem seems to be that Artwork isn't actually copied, as Clipboard doesn't show it. So this doesn't seem to be a MediaMonkey bug.