View Issue Details

IDProjectCategoryView StatusLast Update
0016574MediaMonkey 4Playlist / Searchpublic2020-06-04 16:21
Reporterpeke Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version4.1.29Fixed in Version4.1.29 
Summary0016574: Playlist: Refresh of Playlist in 1905 is more then 5x slower than in 1897 (on some databases)
DescriptionRefresh of Playlist in 1905 is 5x slower than in 1897 and 8x-10x slower than in MM5.
Additional InformationNLJ-143-82227 and https://www.mediamonkey.com/forum/viewtopic.php?f=1&t=96439
TagsNo tags attached.
Fixed in build1906

Relationships

related to 0016432 closedLudek MediaMonkey 5 Optimize database (complete) fails on databases larger than 4 GB 

Activities

Ludek

2020-05-05 10:48

developer   ~0057862

Last edited: 2020-05-05 11:36

View 2 revisions

I can replicate with the user's library.

This is combination of fix 0016432 and the old SQLite3MM.dll used in MM4.

We could either:
- consider it as fixed in MM5
- use the new SQLite3MM.dll from MM5 also in MM4 (not sure about all the impacts however)
- revert 0016432

Ludek

2020-05-05 11:31

developer   ~0057863

Last edited: 2020-05-05 11:32

View 2 revisions

I reverted 0016432 for 4.1.29

We would need to use MM5's SQLite3MM.dll otherwise (which might be risky for MM4)

peke

2020-05-21 22:08

developer   ~0058164

Verified 1906

Looks like it is fixed. Speed is same as in 1897

peke

2020-06-04 16:21

developer   ~0058449

Re verified 1907

Closing