View Issue Details

IDProjectCategoryView StatusLast Update
0016562MediaMonkey 5Main Panel: Toolbars & Menuspublic2020-05-01 20:40
Reporterpeke Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Product Version5.0 
Target Version5.0 
Summary0016562: Album art: Playing/Selected Track Album art is incorrect and can't be removed
Description1. Apron MM5 Start Album art last cached album art (without save icon is shown) and then Auto Search triggers.

2. After changing Selected track and get back album art changes from searched to previous cached one and now Save icon is shown.

3. If I try to remove album art and then open pin in large window it shows empty, but after closing and reopening image is shown. Expected behavior fro remove would be to clear image cache till selection is changes and recache/search again when user select that track again.

Video and log while doing steps in video.
TagsNo tags attached.
Fixed in build

Relationships

related to 0016480 closedmichal Album Art: image handling issues for 'unsaved images' 

Activities

rusty

2020-05-01 17:05

administrator   ~0057819

Peke, can you please update this bug with steps to replicate the issues. It sounds like a duplicate of 0016480 , but the description and lack of repro steps make it unclear what the problem is.

p.s. there's no video link and no video on the ftp server.

michal

2020-05-01 18:00

developer   ~0057821

Video was sent by Skype.
At first it showed artwork assigned to the file. This artwork was deleted by Peke. Empty artwork in image detail dialog was caused by the fact, that Peke opened this dialog during deleting the image, dialog could not display deleted image then, so I think it is not in fact bug, as the source image was deleted during opening the dialog, so this dialog had nothing to show then. The next attempt opened newly autosearched image as it should.
The rest will be solved with 0016480, it is related to improving handling of cached images, as currently it is not possible to remove cached image for ever, it is always recovered back by next autosearch.

rusty

2020-05-01 20:40

administrator   ~0057824

Thanks. Closing.