View Issue Details

IDProjectCategoryView StatusLast Update
0016530MediaMonkey 5Main Panelpublic2021-05-15 21:17
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0016530: Add Play Shuffled options to Context menu of Media Tree nodes
DescriptionWhen selecting files you have 2 Play Shuffled options in their Context Menu. It would be nice if this is also available in the Context Menu of Media Tree nodes where several Play options are already present.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=33&t=99023
TagsNo tags attached.
Fixed in build2405

Activities

rusty

2020-05-19 17:15

administrator   ~0058118

Seems to make sense as the Play Shuffled options apply even better to sets of tracks (nodes) than to individual tracks in the tracklist.

i.e. we should add back Play shuffled and Play Shuffled by album contextual entries for all nodes that currently have Play Now/Next/Last entries.

Ludek

2021-05-12 16:10

developer   ~0063148

Fixed in 2404

rusty

2021-05-12 21:53

administrator   ~0063161

Works well in 2404, just a minor issue remains:
In 2402 all first level nodes (e.g. Albums, Genres, Artists, etc.) have active commands for Play Now, Play Next, Play Last. In 2404, that's still the case, but the Play Shuffled and Play Shuffled (by Album) entries are disabled.

In truth I'm not sure whether most commands should even be enabled at that level, however, for now we should at least make this feature consistent with others.

Ludek

2021-05-13 16:36

developer   ~0063189

Fixed in 2405

peke

2021-05-15 21:17

developer   ~0063229

Verified 2405

Looks like all is unified for now.