View Issue Details

IDProjectCategoryView StatusLast Update
0016523MediaMonkey 5Now Playingpublic2021-01-19 07:04
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016523: MiniPlayer: Tooltips lock the UI
DescriptionOn some occasions, when the user switches to the miniplayer after launching MM, interaction with the miniplayer causes a tooltip to appear and the UI becomes non-responsive for a few seconds or as long as a minute.

e.g. https://www.screencast.com/t/XVBbRyG7SgGH

I've also attached a debug log of this in which the UI stopped responding for about 20 seconds (until moving the miniplayer caused the tooltip to disappear).
TagsNo tags attached.
Fixed in build2287

Relationships

related to 0016711 newpetr MiniPlayer: Window handling issues (maximize button appears 'hot' + responsiveness) 
related to 0017329 newpetr No Tooltips in the MiniPlayer/MicroPlayer 
related to 0017408 resolvedpetr MiniPlayer: UI stops responding 

Activities

rusty

2020-04-17 19:21

administrator  

petr

2020-07-21 11:41

developer   ~0059042

Unable to reproduce in current build. Please retest.

peke

2020-07-31 01:06

developer   ~0059190

Also unable to replicate in 2262

rusty

2020-08-11 01:43

administrator   ~0059320

Verified 2262.

rusty

2020-12-16 18:17

administrator   ~0060814

I'm able to replicate this in 2285 with a different set of steps:
1 Run MM
2 Minimize to miniplayer
3 Close MM
4 Run MM
--> MM restarts in MiniPlayer
5 Click the 'restore' button
--> Button is highlighted, but nothing happens
6 Attempt to click it again
--> UI is frozen

The workaround is to either force-close MM OR to right-click the MM icon in the system tray and click 'Restore' but most users won't realize this.

petr

2020-12-16 21:52

developer   ~0060835

Disabled tooltips to prevent crash/freeze in mini player

peke

2020-12-19 17:44

developer   ~0060941

Verified 2288

Confirming that tooltips are disabled.