View Issue Details

IDProjectCategoryView StatusLast Update
0016447MediaMonkey for AndroidDBpublic2020-04-01 01:52
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version1.3.7 
Target Version1.3.8Fixed in Version1.3.8 
Summary0016447: Album art from Android Media Scanner doesn't display
DescriptionIf the user adds tracks to their device from outside of MediaMonkey (e.g. manual copy using Windows explorer OR copy to SD card), then album art generally displays in other apps, but not in MediaMonkey (tested with GPM, Gonemad).

The issue has been reported in a couple of reviews with 1.3.6 (Android 10 / Samsung devices), and in the forum with 1.3.7 (Android 10 / different devices). I've been able to replicated it with 1.3.8.910 on an S10 running android 10.
Steps To Reproduce1 Connect device to PC
2 Copy 2 directories of tracks with tagged artwork to the device's SD storage using Windows Explorer
3 Disconnect the device
4 Run MMA, and verify whether artwork appears after scan has completed
--> Artwork is missing
5 Verify in other apps (airplane mode to prevent lookups)
--> Artwork displays
6 Verify in MMA again (in case running GPM caused the artwork to somehow get scanned)
--> Artwork is missing

Debug log: QDYKTYRJ1F
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=26&t=95824
https://www.mediamonkey.com/forum/viewtopic.php?f=26&t=96058
TagsNo tags attached.
Fixed in build912

Activities

martin

2020-03-30 12:22

developer   ~0057407

Last edited: 2020-03-30 15:01

View 2 revisions

Completely different processing of album arts on Android 10
because
https://developer.android.com/reference/android/provider/MediaStore.Audio.AlbumColumns#ALBUM_ART
is deprecated with a null value, used recommended approach ContentResolver#loadThumbnail instead.
Newly supported track album art.

Fixed in build 1.3.8.911

rusty

2020-03-30 20:55

administrator   ~0057414

Last edited: 2020-03-30 21:34

View 4 revisions

Triggers multiple crashes when new files are scanned:
1 Install 910
2 Copy 3 tracks (2 by Nina Simone and 1 by Dave Brubeck) via USB
3 Run build 910
--> no artwork
4 Install 911 and run
5 Search for Nina, and click 'Nina Simone'
--> multiple auto-submitted crashes (around 4:50pm EST)
Manually sent log: 61ERZRNJZR

EDIT: when I just copy files straight into build 911, the issue doesn't occur. Please let me know if you see anything in the log.
EDIT2: I tested the above steps on a second device and could not replicate. If the logs don't reveal anything, I'd suggest that we post to Beta.

martin

2020-03-31 07:29

developer   ~0057419

Fixed in build 1.3.8.912

rusty

2020-04-01 01:52

administrator   ~0057431

Verified 912.