View Issue Details

IDProjectCategoryView StatusLast Update
0016437MediaMonkey 5Main Panelpublic2021-02-22 16:50
Reporterpetr Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016437: Views: refreshing reverts sorting / columns / column order in several cases
DescriptionWhen I refresh any tab that uses a custom view based on "List (by Album)", the sort order, displayed columns, column order and column widths all still revert to the defaults for "List (by Album)". When I close MM and reopen it, the custom view is initially displayed exactly as defined, until the next time the tab is refreshed.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95912
TagsNo tags attached.
Fixed in build2239

Relationships

related to 0016391 resolvedrusty List views are not configured/saved per-node 
related to 0014945 closedmichal Ability to restore default sorting 
has duplicate 0016463 closedpetr 'Choose Columns' resets column widths 
related to 0016322 closedpetr View configuration: Sort config doesn't match sort order 
related to 0016466 closedmichal Recently used columns not updated after changes in Choose Columns dialog 

Activities

petr

2020-03-17 12:21

developer   ~0057208

Fixed

rusty

2020-03-18 21:17

administrator   ~0057222

Last edited: 2020-03-18 21:34

View 6 revisions

Test note (based on testing of the issues initially reported by the user):
B) the issue occurs even with the non-custom List (by Album) view in 2232. e.g.
1 Switch to Music > all tracks [List (by album)]
2 Reset Sort (sorts by Album, Album Artist)
3 Sort by Rating
4 Press F5
--> View is resorted by Album, Album Artist!

C) The issue also occurs with other custom views based e.g. on 'List' views. For example:
 View Name: Test
 View type: List
 Sorting: Artist: A..Z
 Columns: whatever...
1 Switch to Music > All tracks [Test]
2 Sort by Album (by clicking the Album column)
3 Press F5
--> Sort reverts to Sort by Artist

D) Similarly Columns and Column order do not persist for the original case OR cases B) and C)

rusty

2020-03-18 21:40

administrator   ~0057223

Re-opened since Petr indicated that C) and D) aren't covered by the fix.

petr

2020-03-19 08:12

developer   ~0057226

Fixed

peke

2020-03-22 23:49

developer   ~0057279

Verified 2234

Unable to replicate using steps described bellow.

rusty

2020-03-23 02:41

administrator   ~0057284

Tested 2234 and there still seem to be issues:
A) View still seems to revert to the last used non-default sort order
1 Open Music > Genres > Aoustic Rock
--> Sort is by: Album Artist ascending, Album ascending, Disc# ascending, Track# ascending, Title ascending! Shouldn't MM sort by the default sort in a new session?
2 Click Manage Views > List (by album)
--> Sorting (= Default Sort) is shown as: Album ascending, Album Artist Ascending
3 Click Reset Sort
--> MM sorts according to the sort at step 2 (as expected)

B) Pressing F5 after Sorting Music > Genres > AcoustickRock [List (by album)] by Rating
--> all tracks are ungrouped!

https://www.screencast.com/t/ga3eBwBMGf3m


C) not tested
D) to be tested as part of 0016391

petr

2020-03-23 11:44

developer   ~0057288

Last edited: 2020-03-23 21:38

View 2 revisions

re A) what did you meant by 'new session' ? Clean install ? Did you choose to import settings ?
re B) fixed

rusty

2020-03-24 16:58

administrator   ~0057319

re. A) I meant run MM5 after it had previously been closed.

petr

2020-03-24 17:48

developer   ~0057322

Last edited: 2020-03-24 17:53

View 2 revisions

re A) After MM restart view will restore it's previous state (columns, sorting etc.). Do you think there're some views which should restore to default (not to save/restore previous state) ?

rusty

2020-03-24 22:40

administrator   ~0057332

Re. A) let me first take a step back and explain a bit of my confusion. When I'd written (at 0016391:0057239 ):
" 4) The current implementation re. default sorts is ch1), however, this is problematic because it results in sorts that aren't necessarily visible in the default view. We could either:
- define new default sort orders that are better suited to the default views
- OR better yet, take the ch2) approach so that users can re-define the default sort orders"

...I wrote ch2) instead of ch1)! i.e. I meant to write 'OR better yet, take the ch1) approach so that users can re-define the default sort orders". That way it avoids the issue of ch2 where a) it's a bit more important to define really good sort orders b) there's no way to easily revert to a known good sort order.

That said, as I originally wrote at 0016391:0057231, I don't think that this is a huge issue, and some users might even prefer it the ch2) implementation because it's consistent with column configuration. So we can continue with the ch2) approach, and hide the 'reset sort order' command since it should no longer do anything (I'd keep the string in case we need to change this).
---------------------------------------------------------------------------------------------------------------------
With the above in mind, issue A) is really about the fact that when a new session is started, there were 2 different sort orders for the view:
i) The sort order that appears
ii) The sort order that's displayed in 'Manage Views...'
I'm no longer able to replicate this, though, other than by using the reset sort order functionality. e.g.
1 Sort by Rating
2 Close / Restart MM
3 Reset Sort order
--> different sort order is displayed!

Assuming we continue with ch2) this problem will be resolved once we remove the 'reset sort order' function.

petr

2020-03-25 09:09

developer   ~0057336

Removed 'Reset sorting' popup command.

rusty

2020-03-30 14:51

administrator   ~0057412

Last edited: 2020-03-30 14:52

View 2 revisions

Columns / Column Order / Sorting seem to save correctly in 2237 (tested thus far primarily with List views), however, in some cases when the user adds/removes a column or changes the sort order --> other column widths are reset!

This doesn't happen consistently. I replicated at as follows:
1 Switch to Music > Files to Edit > Duplicate Titles
2 Set 'Path' column to 2 characters wide
3 Right-click on the header and 'Choose columns'
4 Add 'artwork'
5 Move the Artwork field from position 12 to position 1 (in the Choose Columns dialog) and click OK
--> Column appears as expected, but the Path column displays at full width

It's relatively easy to replicate by switching nodes/views and editing column/sort settings, but I can't figure out a set of repro steps to replicate it consistently.

petr

2020-04-01 12:07

developer   ~0057434

Fixed

peke

2020-04-08 00:48

developer   ~0057541

Verified 2239

Unable to replicate.

peke

2020-06-12 22:03

developer   ~0058527

Re verified 2256