View Issue Details

IDProjectCategoryView StatusLast Update
0016336MediaMonkey 5Syncpublic2020-10-25 14:05
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016336: USB drive appears with incorrect drive letter name
DescriptionSome drives display with the wrong drive letter in MediaMonkey. e.g.
1 Plug in drive
--> appears as drive F: in Windows
--> appears as drive G: in MediaMonkey > Devices and Services

I expect that this is because the drive was previously been plugged in while MediaMonkey was running, and was identified under a different drive letter at that time. Assuming that's the issue, would it make sense to display such drives in Devices and Services using their Labels instead?

https://www.screencast.com/t/Ysu4Z6kcd5
TagsNo tags attached.
Fixed in build2227

Activities

rusty

2020-02-04 04:23

administrator  

Ludek

2020-02-04 13:00

developer   ~0056513

Last edited: 2020-02-04 13:01

View 3 revisions

OK, the problem seems to be that this kind of USB drives has no media label so MM4/MM5 uses "G:\" as the label.
I tried to test with the same kind of USB stick and when I renamed "E:\" to "G:\" manually then I see "G:\ (E:)" in MM4 and "G:\" in MM5.
Both MM4/MM5 looks strange after the renaming.

I guess that solution could be that whenever the name of the profile is just X:\ (where X is a capital letter) then we should always auto-rename it to the current drive letter after connecting.

drives.png (12,834 bytes)   
drives.png (12,834 bytes)   

Ludek

2020-02-04 13:41

developer   ~0056514

Fixed in 2227

peke

2020-10-25 14:05

developer   ~0059991

Verified 2271

This is really more pleasing now.