View Issue Details

IDProjectCategoryView StatusLast Update
0016329MediaMonkey 5Syncpublic2020-12-28 22:26
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016329: Deleting content from USB-attached device --> crash
Description1 Connect Android device via USB
2 Select Music and delete a track
--> MM attempts to update the device database continually but fails (shown by the endless hourglass)
3 Cancel the process
4 Attempt to exit MM
--> crash

https://www.screencast.com/t/LBQBll4V

Note: this issue was originally raised at 0016208
TagsNo tags attached.
Fixed in build2227

Relationships

related to 0013280 closedLudek MediaMonkey (current) Show error message when MTP is frozen 
related to 0016340 closedLudek MediaMonkey 5 Andorid devices: Empty folders are not removed upon deletion of files 
related to 0017298 closedLudek MediaMonkey 5 MTP Freeze dialog can show multiple times 

Activities

rusty

2020-01-31 19:20

administrator  

MediaMonkeyEngine.7z (6,970 bytes)

Ludek

2020-01-31 20:00

developer   ~0056453

Last edited: 2020-01-31 20:03

View 4 revisions

The strange is that the EL includes just: " Cannot use EurekaLog's functions in module "MediaMonkeyEngine.exe" without activated EurekaLog"
It seems that Eureka is not activated in 2224 ?

But based on the debug log it is the notorious MTP freeze issue after a file deletion (you can verify that Windows Explorer is also frozen when accessing the files on the storage), we had the "media transfer protocol forzen" message, but it is shown only once after 2 minutes ( 0013280 )

Currently I have no other idea than just lowering the timeout for the message to something lower than two minutes ?

Ludek

2020-02-05 14:44

developer   ~0056535

Fixed in 2227

- lowered the MTP freeze timeout from 2 minutes to 30 seconds (to show the freeze message in time)
- fixed the crash on closing
- fixed the progress bar (it was missing the deletion text)

peke

2020-07-02 00:35

developer   ~0058724

Verified 2259

Unable to reproduce even by trying to delete/access/browse/play while sync is ongoing with device.