View Issue Details

IDProjectCategoryView StatusLast Update
0016319MediaMonkey 5Main Panel/Toolbars/Menuspublic2020-03-02 15:45
Reporterpeke 
PriorityurgentSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016319: Toolbar: prev/next view button is missing dropdown
DescriptionUnlike in MM4 in MM5 Prev/Next are missing Dropdown even history is available on Right click
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95755
TagsNo tags attached.
Fixed in build2228

Relationships

related to 0016406 feedbackLudek Mouse improvements: horizontal scrolling and back/forward buttons 

Activities

peke

2020-01-30 01:57

developer  

bug16319.jpg (11,233 bytes)
bug16319.jpg (11,233 bytes)

Ludek

2020-01-30 10:47

developer   ~0056391

Last edited: 2020-01-30 11:39

View 2 revisions

I don't like adding the dropdowns as the functionality is already available via right-click and long-left-click and the dropdowns would just unnecessary pollute the toolbar.

Your opinion?

EDIT: Maybe we could just expand the tooltip to include a tip to use right-click or left-long-click ?

jiri

2020-01-30 15:10

administrator   ~0056395

I also prefer the cleaner look of MM5, i.e. without the dropdown arrows.

I agree with Ludek, that a longer tooltip might help.

I also wonder whether to include this in the main menu, i.e. View\Previous\{~20 last view history items} and View\Next\{~20 next view history items} ?

rusty

2020-02-14 05:15

administrator   ~0056675

How about:
Previous view (Alt-Left). Right-click for history.
Next view (Alt-Right). Right-click for history.

Ludek

2020-02-14 10:54

developer   ~0056684

Modified the tooltips as suggested in 2228
I also added them to the View menu (as suggested by Jiri).

rusty

2020-02-18 02:58

administrator   ~0056710

Verified 2228. Just a minor tweak re. the Views menu in relation to this change:
Skin/Mode/Main Panel view: can be grouped together.
Previous/Next/Refresh: can be grouped together.

Ludek

2020-02-21 11:21

developer   ~0056778

I don't see why "Skin/Mode/Main Panel view" should be grouped together?

I would rather say that "Main Panel view/Previous/Next/Refresh" should be grouped together as they are all related to the current view.

jiri

2020-02-21 13:15

administrator   ~0056784

The boundaries are rather shady imho, but I'd say that Main Panel View is more related to Mode, which is why I'd rather agree with Rusty and would:
1. move Main Panel View to the section right above it, and
2. move Previous and Next to the section right below it.

However, the differences seems to be tiny, we can as well leave as is and possibly reconsider again in the future.

rusty

2020-02-21 15:30

administrator   ~0056793

The logic is that:
- Skin/Mode/Main Panel view are all config items that are rarely accessed after initial config.
- Previous/Next/Refresh are all 'daily use' actions associated with switching/updating views

Since it's a trivial change, I'd rather just make it now and close the issue, but if you prefer to push to 5.0.1 that's fine--it's a minor point.

Ludek

2020-02-21 16:49

developer   ~0056798

Adjusted the View menu as suggested in build 2229

peke

2020-03-01 03:21

developer   ~0056955

Verified 2229

For me it is clear enough and logical, except Maybe that Backspace is hotkey for Prev. I would also support ALT+Left

Additionally to above Mouse/Browser/Keyboard hotkeys Back/Forward commands do not work also.

peke

2020-03-01 03:28

developer  

Ludek

2020-03-02 12:39

developer   ~0056992

- Alt+Left also works for navigation back -- this action has actually assigned two hotkeys (Backspace and Alt+Left) as you can see in Options > Hotkeys
I don't think that it is necessary to list all the assigned hotkeys in the tootltip ?

- I see that Back/Forward mouse commands are already tracked as item 2) here: 0016406

rusty

2020-03-02 15:45

administrator   ~0056999

Re-resolving for reasons described by Ludek.