View Issue Details

IDProjectCategoryView StatusLast Update
0016277MediaMonkey 5Main Panelpublic2020-08-28 08:33
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016277: Create reports and statistics feature is missing
DescriptionCreate reports and statistics feature is missing from MM5 :
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95792
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95688
Additional Informationhttps://www.npmjs.com/package/xlsx
TagsNo tags attached.
Fixed in build2230

Activities

michal

2020-03-02 18:49

developer   ~0057005

Statistics script implemented in build 2230.

Ludek

2020-03-03 14:00

developer   ~0057025

Seems to work well.

michal

2020-03-03 16:58

developer   ~0057026

Last edited: 2020-03-03 16:58

View 2 revisions

Added exports to HTML, CSV and XML, to build 2230.

peke

2020-03-07 01:12

developer   ~0057097

reopen
1. in File -> Create Reports you can't select XML/HTML/CSV But only Statistics

2. Save As only have save to HTML file (If this is a bug, if not it should state "Save HTML" instead of "Save As...")

michal

2020-03-07 07:58

developer   ~0057101

Last edited: 2020-03-07 08:00

View 3 revisions

1) you need to select tracks for export first
2) it is the same as in MM4

peke

2020-03-08 00:14

developer  

bug16277_1a.jpg (235,844 bytes)   
bug16277_1a.jpg (235,844 bytes)   

rusty

2020-05-20 21:55

administrator   ~0058151

Re-resolving this issue since the MM4 functionality has been successfully ported.

As to the suggested changes:
1) There's room for changes to the terminology, but it's not anything we need to spend time on now. I'll document in a new bug for the future.
2) 'Save as...' is fine since as it signifies that an additional dialog is to be presented (it's true that 'Save' often opens a 'Save as...' dialog if the filename is unknown a priori, so it could also be a 'Save' or 'Save...' dialog but I don't think this makes much of a difference one way or the other.

peke

2020-08-27 19:27

developer   ~0059492

Verified all functionality in 2264

I do not think that there should be any more changes in terminology especially as current one works on all platform and XLS is tied only to Microsoft Office Excel files and COM access to installed office.

I would close it.