View Issue Details

IDProjectCategoryView StatusLast Update
0016020MediaMonkey 5Playlist / Searchpublic2019-10-17 23:32
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016020: Duplicate track prevention in playlists causes non-duplicates to fail to add
DescriptionIf the user attempts to add multiple tracks to a playlist and one/some of them already exists in the playlist, then if the user click 'No' in the Duplicate files confirmation dialog
--> None of the tracks get copied!
The user would expect that the non-duplicates get copied, but not the duplicates.

Note: I don't know if this change was implemented intentionally at some point because I see that the wording has also changed:
MM5: Are you sure you want to add track(s) to the playlist?
MM4: Are you sure you want to add the track(s) to the playlist?

Note: the MM4 wording is preferable because it refers to the duplicate tracks (rather than all tracks)
Steps To ReproduceReported at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95206
TagsNo tags attached.
Fixed in build2204

Activities

Ludek

2019-10-09 13:00

developer   ~0054990

Fixed in 2204

peke

2019-10-17 23:32

developer   ~0055030

Verified 2204

Non duplicates gets copied and and dialog shows MM4 string