View Issue Details

IDProjectCategoryView StatusLast Update
0015996MediaMonkey 5Tagging / organizing (properties / auto-tools)public2020-10-27 10:50
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0015996: Auto Tag: Fails in cases where Albums are already tagged corectly
DescriptionAuto-Tag fail to recognize that tracks are already correctly tagged, and firstly suggest already existing Album Info and its typo corrections.

Instead it changes file tags completely with wrong information.

Video and accompany MM5 log file is uploaded to FTP.
TagsNo tags attached.
Fixed in build2222

Relationships

related to 0015994 feedbackpetr Auto-tag: failure to recommend the original album vs compilation in some cases 

Activities

peke

2019-09-26 21:29

developer   ~0054871

MM4 discogs return correct values.

peke

2019-09-26 21:31

developer  

bug15996.jpg (280,311 bytes)

rusty

2019-09-26 22:25

administrator   ~0054874

Peke's video showed 2 cases:
1) All tracks from Taylor Swift's 'Fearless Karaoke' were tagged with 'Fearless Karaoke'. Unfortunately, the Album was listed as "Taylor Swift Karaoke: Fearless" in musicbrainz ( https://musicbrainz.org/release/f7359257-594a-4f8c-ac97-a17bdcfe9aa0 ) i.e. it didn't match any existing entry in Musicbrainz, so MM's recommendation was for the earlier version of the Album.

The user could have simply changed the album to the correct version, but perhaps we might want to add a rule that if 'Karaoke' appears in the title (of the tracks?), that MM should give preference to a matching album title that labelled as 'karaoke' in musicbrainz. Petr, you can probably come up with the best approach...

2) All tracks from Taylor Swift (Deluxe) were tagged with album title 'Taylor Swift (Deluxe Edition)'. Since this doesn't appear in the musicbrains DB (https://musicbrainz.org/release-group/ba1d0c2a-bb07-38bc-835c-a880f76f1309) , it was changed to what appears to be an identical album.

Again, the user could have switched the album to 'Taylor Swift (Deluxe)' had they wanted. I'm not sure if there's anything we would want to do for this case.

Peke, it seems that the problems that you described are specific to cases in which the Album didn't match entries in MB. Is there problem more general than that as you described?

Petr, what do you think we should make any changes for such cases?

peke

2019-09-27 01:48

developer   ~0054875

Last edited: 2019-09-27 02:00

View 2 revisions

As explained offline MB search is to strict and do not use all the potential of MB:
1. "Taylor Swift Fearless Karaoke" If searched as Release due the fact that Album is Known First result is "Taylor Swift Karaoke: Fearless" ( https://musicbrainz.org/release/f7359257-594a-4f8c-ac97-a17bdcfe9aa0 ) if searched indexed and not DirectDB https://musicbrainz.org/search?query=fearless+karaoke&type=release&method=indexed

2. "Enrique Iglesias - 95/08" is a compilation Album and when tagged on MM5 it is split into two albums instead of just using https://musicbrainz.org/release/47f054bc-6542-4948-953b-a5ea19a381a2 due the fact that one contain only 14 tracks where correct one have 19 tracks

3. "Enrique Iglesias - Christmas EP (2013)" Is not found on MB it exists on https://www.discogs.com/Enrique-Iglesias-Christmas-EP/release/5348619 and recommended result destroy correct info on tracks making them non recognizable from album versions.

4. Lindsy Stirling tracks
a) "Lindsey Stirling - On the Floor" gets recommendation of completely different Artist and track name
b) "Lindsey Stirling and Vibrant Sound - Gold Digger" Gets recommendation that Title is wrong (Supplied original Track s by that title)

Regarding 1: There is clear better way to search thru MB info than direct access of DB.
Regarding 2-4: I would leave Tracks as is and Showed Exclamation mark that there are suggestions for tagging not other way around

Sample files are uploaded to FTP.

Another very big Issue is that using Diskogs Web tag plugin in MM4 finds all those above correctly and tag them, but if tried to retag in MM5 info is wrong and correct metadata gets lost.

petr

2019-09-27 07:26

developer   ~0054876

re 1) different search types are supported just in WEB UI, but not in WS API we're using to communication with MB server

peke

2019-10-03 10:36

developer   ~0054919

Last edited: 2019-10-03 10:37

View 2 revisions

3. Update I wonder if we can use Finger printing to prevent incorrect Tagging and creating Duplicates eg. to decide not to Auto-Tag such tracks and mark them for user attention? See track difference for "Turn the Night Up" example tracks.

peke

2019-10-03 10:37

developer  

petr

2020-01-21 17:18

developer   ~0056089

Last edited: 2020-01-21 17:22

View 3 revisions

1. fixed
2. question is what is correct ? If 19, try to recommend MB to update album (or insert new version) and then it will be detected correctly
3. as you wrote ... this album is not in MB database
4. fingerprint return just one recommendation and it's used

peke

2020-10-27 10:50

developer   ~0060006

1, 4 are re verified 2271

Closing due the fact (as written here) it is matter of perspective/usage rather than functionality.

If users complain we can open new bugs.