View Issue Details

IDProjectCategoryView StatusLast Update
0015991MediaMonkey 5Syncpublic2020-10-27 10:44
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015991: Sync: white-screen on large sync operation
DescriptionWhen doing large sync operations MediaMonkey often crashes with a white screen (no crashlog). In both cases it was a wifi sync initiated by MMA, with auto-conversion enabled for tracks exceeding 256Kbps, so I'm guessing it's related to conversion.

Debug logs for 2 such crashes posted to the ftp (note: debug had been running for quite some time in both cases as I was testing other things so you can ignore the beginning of both of them). Please delete them once you're done--they're quite large (or leave them if you re-assign to ludek).
TagsNo tags attached.
Fixed in build2203

Activities

Ludek

2019-09-30 11:46

developer   ~0054893

Another crashes (or same?) mentioned as item #7 here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95160

Ludek

2019-10-01 12:45

developer   ~0054906

Last edited: 2019-10-01 13:05

View 3 revisions

As for the Barry's crash logs (70CB7919, 83698CC4) -- these are crashes in d_WMDM.dll when finishing synchronization (removing device while syncing).
=> Fixed in 2203

As for the Rusty's debug logs.
I don't see a reason for the crash in the logs, but I noticed that in all three cases MM5 was running for 16 hours at minimum doing various actions (including the large sync).
So I wonder whether there wasn't a memory leak leading to the crash?
I suppose you did not check memory utilization before silent crash? I suppose that you don't have ELP file (crash logs) that would show it?
If you don't have any ELP, could you please initiate a large sync again and check memory utilization time from the time.
e.g. check the memory utilization after one hour of sync, then later after another hour and so on.

rusty

2019-11-01 02:07

administrator   ~0055173

Tagging as Resolved since I haven't observed this issue in some time. I'll close this bug after reverifying.

peke

2020-10-27 10:44

developer   ~0060005

Re verified 2271

I have tried to stress test MM5 by syncing multiple devices at once for prolonged time 18h+ and couldb't observe crash.

Async is working normally and after one thread/sync is done mem usage gets back to normal.