View Issue Details

IDProjectCategoryView StatusLast Update
0015985MediaMonkey 5Synchronizationpublic2019-11-20 15:44
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015985: Synch tree behaves incorrectly / gets corrupted
Description1) There seems to be some strange behavior with the Auto-Sync --> Device tree:
One some occasions (I've seen this occur twice):
1 Uncheck music
--> all collections get unchecked!
--> Albums|Artists|Album Artists show 'partial' check (even though no children are checked)!
2 Uncheck all Music collection children
--> Music node gets 'partial' check!

On other occasions:
1 Uncheck music
--> music and all subnodes get unchecked
2 Uncheck Podcasts
--> Podcast 'subscriptions' node appears partially checked but subnodes appear unchecked!
--> Upon syncing, unchecked podcast syncs!

I'm not sure exactly what the problem is, but it's relatively easy to get the tree to behave strangely as described above.

2) 'Hide unselected items' doesn't work correctly--it acts like a button rather than a checkbox i.e. the setting doesn't persist upon expanding a different node.

aside: if we changed the tree so that checked items appeared first, then we could remove the 'hide unselected items' functionality
TagsNo tags attached.
Fixed in build2214

Relationships

related to 0016112 closedLudek Synch tree fails to update and crashes 

Activities

Ludek

2019-09-30 11:42

developer   ~0054892

Last edited: 2019-10-10 16:01

View 3 revisions

3) Further items related (#1 and 5#) reported here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95160

4) 'Classical music' collection has no subnodes (3 years old regression)

Ludek

2019-10-10 16:06

developer   ~0055003

Last edited: 2019-10-14 16:44

View 5 revisions

Fixed in 2205

rusty

2019-10-24 17:03

administrator   ~0055105

Tested 2207:
1) Mostly fixed except that:
1 Check Music > Rating > 5 stars
--> Music node gets 'partial' check
2 Uncheck Music > Rating > 5 stars
--> Music node still has 'partial' check! (checking and unchecking it a few times causes it to stop being partially checked)
(haven't tested whether the unchecked tracks sync--to test after this is fixed)

2) Mostly fixed except that if the user selects the top level node, the list fails to update. e.g.
1 Select Genres > Accoustic Rock
2 Enable 'Hide unselected items'
--> Tree updates as expected
3 Check Genres
--> Other Genres don't appear selected!
4 Disable 'Hide unselected items'
--> Genres is selected, but it's children (other than accoustic rock) aren't!

Ludek

2019-10-30 13:59

developer   ~0055145

1) I cannot replicate, could you please share screencast of this + your MM5.DB ?

2) is fixed in 2210

rusty

2019-10-30 19:33

administrator   ~0055152

1) I'm no longer able to replicate this in 2209. I'll try again with the next build.

rusty

2019-11-05 14:10

administrator   ~0055202

Tested 2210.
1) Re-verified
2) Verified fix
3) Is testing 2) I noticed that 'Hide unselected items' interacts incorrectly with Collection selection. e.g.
1 Select 1 artist
2 Select Music Collection
3 click/unclick 'Hide unselected items'
--> it appears as if only the 1 artist is selected!

It's a relatively minor issue, but I think there's a simple/trivial solution: if the user selects a collection then:
a) the tree should collapse (since selection in the tree is now meaningless as all items are 'selected'
b) 'hide unselected' shouldn't expand the tree for selected Collections

Ludek

2019-11-05 16:31

developer   ~0055210

Last edited: 2019-11-05 16:34

View 3 revisions

Once the whole collection is selected then the tree on the right is greyed out (disabled), it works the same way as in MM4, see the screenshot.

EDIT: The only difference is that the '[x] Hide unselected' checkbox is also disabled in MM4, so that's probably what you are objecting?
i.e. '[x] Hide unselected' checkbox should be disabled once the whole collection is selected, right?



Device config.png (80,690 bytes)
Device config.png (80,690 bytes)

Ludek

2019-11-05 16:41

developer   ~0055211

Last edited: 2019-11-05 16:57

View 2 revisions

OK, probably better would be to hide the tree on the right entirely like this:

=> implemented in 2211



Device config-2.png (56,624 bytes)
Device config-2.png (56,624 bytes)

rusty

2019-11-05 22:53

administrator   ~0055218

Verified 2211.

rusty

2019-11-14 21:56

administrator   ~0055352

Re-opening as I've figured out the repro steps for issue 1)

1 Check 2 Artists in MM5 sync list
2 Run MMA and verify that the 2 Artists are checked in the sync list
3 In MMA check a 3rd artist and back out to the main screen
4 In MM5, uncheck 'Artists' so that all individual artists are unchecked
--> In MM5, Artists and all child Artists become unchecked, but 'Music' remains 'partially' checked even though no content is in the sync list
--> In MMA, the Artist that was added in step 3 remains checked, and will sync despite the fact that MM5 shows no Artists in the sync list

https://www.screencast.com/t/kuQLarcikS

Unchecking_top-level-node_causes_sync-list-to-not-match-db.7z (445,167 bytes)

Ludek

2019-11-20 15:44

developer   ~0055420

Fixed in 2214