View Issue Details

IDProjectCategoryView StatusLast Update
0015976MediaMonkey 5Playlistspublic2020-07-28 00:30
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015976: Importing m3u8 created by iTunes skips files with international characters in the path
DescriptionWhen importing m3u8 created by iTunes, MM5 leaves out files, where path or filename contains non-ASCII letters. They are missing from imported playlists then.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=461763#p461763
https://www.mediamonkey.com/forum/viewtopic.php?f=1&t=95178
TagsNo tags attached.
Fixed in build2201

Relationships

related to 0016015 closedmichal MediaMonkey (current) Importing m3u8 created by iTunes skips files with international characters in the path 

Activities

michal

2019-09-23 08:08

developer   ~0054785

2) Another issue with m3u8 - these playlists cannot be dropped to nowplaying list

michal

2019-09-23 11:10

developer   ~0054790

Fixed in build 2201. The main problem was caused by the fact, that iTunes generated UTF8 file does not contain byte order mark, we should now handle such better.

peke

2019-09-23 14:38

developer   ~0054800

Last edited: 2019-09-23 14:40

View 2 revisions

Can you please elaborate for future testing and KB?

Have you made that M3U8 is always assumed to be UTF-8 encoded even BOM is missing?

michal

2019-09-23 16:58

developer   ~0054809

peke: MM5 now tries to detect, whether UTF8 characters are present in the m3u8 file. It is doing this also for m3u files, because iTunes saves it in UTF8 without BOM too.

peke

2019-09-23 17:14

developer   ~0054810

Thx for clarification.

I would suggest that M3U8 are not checked, just assumed to be UTF-8 with or without BOM

For M3U I would only do a check if on importing file is not accessible eg. on first check check for UTF-8 and load rest of file as UTF-8 if TRUE, otherwise load it as is.

Add above only if it will optimize loading speed on large playlists. otherwise just resolve bug so that I can test it in 2201

peke

2019-10-03 02:26

developer   ~0054916

User complain with same behavior in MM4

michal

2019-10-04 08:01

developer   ~0054939

Merged to MM4 (issue 0016015)
Closing.

peke

2020-07-28 00:30

developer   ~0059155

Verified 2261