View Issue Details

IDProjectCategoryView StatusLast Update
0015939MediaMonkey 5Track Browserpublic2019-09-19 13:44
Reporterrusty 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015939: Double-click of thumbnails in grid views opens pop-up
DescriptionThis causes the pop-up to always open:
1 Navigate to Genres
2 Double-click Genre-Name
--> GenreName view opens
3 Press BACK
--> Genres view appears but Genre-Name popup is open!!

Note: this affect Artists, Albums, Composers, etc. (ie. double-clicking any thumbnail in a grid view).


This causes the pop-up to sometimes open:
1 Navigate to Genres
2 Double-click Genre-Name
--> GenreName pop-up opens

Note: this can occur when double-clicking Artists, Albums, Composers, etc. thumbnails in any view.
TagsNo tags attached.
Fixed in build2198

Relationships

related to 0015943 closedmichal Double-clicking item in grid sometimes does not trigger double-click action. 

Activities

Ludek

2019-09-11 14:20

developer   ~0054592

I guess that the issue is that pop-up seems opened on mouse down (instead of single-click) ? So it is opened also in case of double-click.

Ludek

2019-09-11 14:29

developer   ~0054593

Related issue to look into: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95077

michal

2019-09-13 14:35

developer   ~0054631

No, popup opens on click. But click is always called before double-click.

michal

2019-09-13 16:34

developer   ~0054632

Last edited: 2019-09-13 16:38

View 3 revisions

Original issue fixed in build 2197. Note, it still start opening popup, because during first click it does not know, whether second click will follow. And postponing leads to look like laggy app. response, that does not feel good. But popup should be closed immediately now.

Issue from forum seems to be different issue, when double-click event does not occur sometimes for some unknown reason, will be solved separately as 0015943

rusty

2019-09-13 19:10

administrator   ~0054637

Tested 2197 and the fix seems to work.

I'm still not happy with how double-click will often initially trigger single-click behavior prior to initiating the double-click. If double-click in Explorer can open a file without triggering the single-click (in-place edit) behavior, why can't we do the same here?

michal

2019-09-13 19:15

developer   ~0054639

Last edited: 2019-09-13 19:16

View 3 revisions

Rusty: as I wrote above, it looks very laggy. You click and have to wait about 0.5s for opening the popup (it seems, Explorer also waits such time). We were trying this in the past, but the feeling was like the application is very slow.

michal

2019-09-14 15:55

developer   ~0054646

Fixed in build 2198. It showed up, that 0015943 was caused by opening popup after the first click. So I really added some waiting for the second click of double-click, so currently popups will open slightly later. Hopefully it won't look so bad.

peke

2019-09-18 01:12

developer   ~0054670

Verified 2198

double-clicking any thumbnail in a grid view for available views with Grid view works, as pointed single click is bit delayed.

For me it works OK, can you confirm if delay timings are OK, maybe it can be lowered bit more.

rusty

2019-09-19 13:43

administrator   ~0054707

The fix seems good to me. Re-resolving and closing.