View Issue Details

IDProjectCategoryView StatusLast Update
0015873MediaMonkey 5Properties/Auto-Toolspublic2019-08-14 21:25
Reporterpeke 
PriorityurgentSeveritytweakReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target Version5.0Fixed in Version 
Summary0015873: Drag And Drop: Album art Only tag Focused track not whole selection
DescriptionIf User drag and drop album art on Art and Details window, Album art Only tag Focused track not whole selection
Steps To Reproduce1. Select Several number of tracks
2. Set Art and details on Selected
3. drag and drop album art
4. Only focused track is tagged
TagsNo tags attached.
Fixed in build

Activities

Ludek

2019-08-12 21:41

developer   ~0054320

Last edited: 2019-08-12 21:41

View 2 revisions

Do you mean 'Art & Details' window?
If yes then I would say that it is expected that only the selected track (the one that is shown in the A&D window) is tagged?
A&D currently cannot show multiple files selection and it would be strange and unexpected to tag tracks that are not shown in the A&D window, or am I missing something?

peke

2019-08-13 02:19

developer   ~0054321

Behavior is different from MM4.

In MM4 on A&D Window context menu you have Add Image that allow you to select add to all album series, MM5 do not have that, same goes for Drag and Drop.

If you select all tracks from same Album/TV Series and use Drag and Drop it should be assumed that if A&D window is for Selected tracks it should tag all tracks or at least make user selectable that all selected tracks are to be tagged.

Ludek

2019-08-14 10:59

developer   ~0054343

Last edited: 2019-08-14 11:02

View 3 revisions

I think that user expects to edit just the selected track in the A&D window, not any other track(s) that were selected (not showning in the A&D window) -- which would rather results in unintended artwork assignment when the tracks are not from the same album/series.

In addition the '[x] Apply to all files in album/series''checkbox is checked by default, see: https://www.dropbox.com/s/onwjp3p5ggkd0kl/Screenshot%202019-08-14%2012.56.32.png?dl=0
Why should user bother with selecting all the albums tracks manually if there is the checkbox? I don't see the point at all.

Assigned to Rusty to review, but I don't see a bug here. I would suggest to just close this as "no change required"

rusty

2019-08-14 21:25

administrator   ~0054354

I agree with Ludek, although I can also understand why it might be confusing.
The root of the issue is that the 'Preview' window only represents a single track even when multiple tracks are selected. So if the user attempts to edit the metadata for the item that is selected, MM should only edit the metadata for that single track. Another way of looking at it is that if MM would edit the artwork for all of the selected tracks, then the dialog should also edit the _metadata_ for all of the selected tracks (definitely not expected)!

We went through this debate with MM4 as well, and that's we we made sure to add the option to update all tracks on the album (for artwork).

p.s. I tested the behavior in MM4 and it's the same.

Resolving(won't fix).