View Issue Details

IDProjectCategoryView StatusLast Update
0015858MediaMonkey 5DBpublic2019-08-31 21:40
ReporterLudek Assigned To 
PriorityimmediateSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015858: MM4 vs MM5 database compatibility issues
DescriptionCurrently if user defines custom DBName in the INI file and uses the database by both MM4 and MM5 versions simultaneously then MM4 throws dialog that the database is not MM4 compatible.

We have added workaround (ForceMM4Compatibility flag to the INI file, with this INI options enabled the MM5 > Rebuild database) makes the DB backward compatible with MM4 (see #15151).
This is hard to realize for users though and we agreed that this functionality shouldn't be promoted (see 0015151:0051347)

Possible solutions:
a) rename mm.db to mm5.db so that such a unintended sharing of single database by MM4 and MM5 instances is not possible (preffered).

EDIT: This is strongly preferred solution, because we should guarantee what we claims:
"Installation of MediaMonkey 5 can be on top of MediaMonkey 4, or independent of MediaMonkey 4. If you run both versions, changes made in one DB will not be reflected in the other."
which is not the case currently!
This solution also covers the case when users installs MM5 portable on top of MM4 portable (to retain MM4 database untouched by MM5)

b) Add '[ ] Force version 4 compatibility' checkbox to 'Manage database' dialog with tooltip '...leads to worse performance...' and makes this checkbox enabled by default when custom DBName location is specified in the INI

Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=94902
TagsNo tags attached.
Fixed in build2191

Activities

petr

2019-08-07 12:26

developer   ~0054285

Fixed

peke

2019-08-09 20:43

developer   ~0054310

Verified 2191

Will be closed after user Confirmation

peke

2019-08-31 21:40

developer   ~0054493

User confirmed.

Closing.